# CVE-2023-48713: Knative Serving vulnerable to attacker-controlled pod causing denial of service of autoscaler

> An attacker controlling a pod's metrics endpoint can cause a denial of service in the Knative autoscaler via unbound memory allocation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2023
- **Updated:** 11 Oct 2024
- **Also known as:** CLEANSTART-2026-LH10039, CLEANSTART-2026-NU71361, GHSA-qmvj-4qr9-v547, GO-2023-2355

## What is CVE-2023-48713?

CVE-2023-48713 is a medium-severity denial of service vulnerability in knative serving, published on 28 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Knative Serving builds on Kubernetes to support deploying and serving of applications and functions as serverless containers. An attacker who controls a pod to a degree where they can control the responses from the /metrics endpoint can cause Denial-of-Service of the autoscaler from an unbound memory allocation bug. This is a DoS vulnerability, where a non-privileged Knative user can cause a DoS for the cluster. This issue has been patched in version 0.39.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-48713?

3 open source packages ship an affected version, including knative.dev/serving. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knative.dev/serving` | Go | All versions | 0.39.0 |
| `knative.dev/serving` | Go | All versions | 0.39.0 |
| `knative.dev/serving` | Go | All versions | 0.39.0 |

Products: Knative Serving.

## How do I fix CVE-2023-48713?

Upgrade knative.dev/serving to 0.39.0 or later.

## Is CVE-2023-48713 being exploited?

There is no known exploitation of CVE-2023-48713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48713 and fix it if it is affected.

What it is: CVE-2023-48713 is a medium-severity denial of service vulnerability in knative serving, published on 28 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48713 in the wild and no public exploit code.

Affected packages and fixed versions:
- knative.dev/serving (Go): affected all versions; fixed in 0.39.0
- knative.dev/serving (Go): affected all versions; fixed in 0.39.0
- knative.dev/serving (Go): affected all versions; fixed in 0.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48713/ (Markdown: https://insights.sbomify.com/CVE-2023-48713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48713
- OSV: https://osv.dev/vulnerability/CVE-2023-48713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48713/
Summaries are generated and may contain mistakes; the official description above is the record.
