# CVE-2023-48714: Record titles for restricted records can be viewed if exposed by GridFieldAddExistingAutocompleter

> Attackers can view titles of restricted records via GridFieldAddExistingAutocompleter, exposing sensitive data to unauthorized users.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-qm2j-qvq3-j29v

## What is CVE-2023-48714?

CVE-2023-48714 is a medium-severity vulnerability in silverstripe-framework, published on 23 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Silverstripe Framework is the framework that forms the base of the Silverstripe content management system. Prior to versions 4.13.39 and 5.1.11, if a user should not be able to see a record, but that record can be added to a `GridField` using the `GridFieldAddExistingAutocompleter` component, the record's title can be accessed by that user. Versions 4.13.39 and 5.1.11 contain a fix for this issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-48714?

4 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | All versions | 4.13.39 |
| `silverstripe/framework` | Packagist | All versions | 4.13.39 |
| `silverstripe/framework` | Packagist | From 5.0.0 | 5.1.11 |
| `silverstripe/framework` | Packagist | From 5.0.0 | 5.1.11 |

Products: Silverstripe Framework.

## How do I fix CVE-2023-48714?

Upgrade silverstripe/framework to a fixed version for your release line: 4.13.39 or 5.1.11.

## Is CVE-2023-48714 being exploited?

There is no known exploitation of CVE-2023-48714 in the wild and no public exploit code.

## Other vulnerabilities in silverstripe-framework

- [CVE-2022-38148](https://insights.sbomify.com/CVE-2022-38148/): Blind SQL Injection via GridFieldSortableHeader (high 8.8)
- [CVE-2022-38462](https://insights.sbomify.com/CVE-2022-38462/): Reflected XSS in querystring parameters (medium 6.1)
- [CVE-2025-30148](https://insights.sbomify.com/CVE-2025-30148/): Silverstripe Framework has a XSS vulnerability in HTML editor (medium 5.4)
- [CVE-2024-53277](https://insights.sbomify.com/CVE-2024-53277/): Cross-site Scripting in form messages in silverstripe framework (medium 5.4)
- [CVE-2024-32981](https://insights.sbomify.com/CVE-2024-32981/): Cross-site Scripting vulnerability with encoded payload in silverstripe/framework (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48714 and fix it if it is affected.

What it is: CVE-2023-48714 is a medium-severity vulnerability in silverstripe-framework, published on 23 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48714 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected all versions; fixed in 4.13.39
- silverstripe/framework (Packagist): affected all versions; fixed in 4.13.39
- silverstripe/framework (Packagist): affected from 5.0.0; fixed in 5.1.11
- silverstripe/framework (Packagist): affected from 5.0.0; fixed in 5.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48714/ (Markdown: https://insights.sbomify.com/CVE-2023-48714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48714
- OSV: https://osv.dev/vulnerability/CVE-2023-48714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48714/
Summaries are generated and may contain mistakes; the official description above is the record.
