CVE-2023-48796 Apache dolphinscheduler sensitive information disclosure

High 7.5 Published Updated

Unauthorized actors can access sensitive data, including database credentials, via exposed management endpoints in Apache DolphinScheduler.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-48796?

CVE-2023-48796 is a high-severity vulnerability in Apache DolphinScheduler, published on 24 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler.

The information exposed to unauthorized actors may include sensitive data such as database credentials.

Users who can't upgrade to the fixed version can also set environment variable `MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus` to workaround this, or add the following section in the `application.yaml` file

``` management:   endpoints:     web:       exposure:         include: health,metrics,prometheus ```

This issue affects Apache DolphinScheduler: from 3.0.0 before 3.0.2.

Users are recommended to upgrade to version 3.0.2, which fixes the issue.

Weakness: CWE-200

Which versions are affected by CVE-2023-48796?

5 open source packages ship an affected version, including apache-dolphinscheduler and org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.

PackageAffectedFixed in
apache-dolphinscheduler PyPIFrom 3.0.03.0.2
apache-dolphinscheduler PyPIFrom 3.0.03.0.2
apache-dolphinscheduler PyPIFrom 3.0.03.0.2
org.apache.dolphinscheduler:dolphinscheduler MavenFrom 3.0.03.0.2
org.apache.dolphinscheduler:dolphinscheduler MavenFrom 3.0.03.0.2

Products include Apache Dolphinscheduler.

How do I fix CVE-2023-48796?

Upgrade apache-dolphinscheduler to 3.0.2 or later.

Is CVE-2023-48796 being exploited?

There is no known exploitation of CVE-2023-48796 in the wild and no public exploit code.

Sources

Also known as GHSA-4vvc-r4p4-qgrr, PYSEC-2023-268.

Is CVE-2023-48796 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free