# CVE-2023-48796: Apache dolphinscheduler sensitive information disclosure

> Unauthorized actors can access sensitive data, including database credentials, via exposed management endpoints in Apache DolphinScheduler.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2023
- **Updated:** 28 Nov 2025
- **Also known as:** GHSA-4vvc-r4p4-qgrr, PYSEC-2023-268

## What is CVE-2023-48796?

CVE-2023-48796 is a high-severity vulnerability in Apache DolphinScheduler, published on 24 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler.

The information exposed to unauthorized actors may include sensitive data such as database credentials.

Users who can't upgrade to the fixed version can also set environment variable `MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus` to workaround this, or add the following section in the `application.yaml` file

```
management:
  endpoints:
    web:
      exposure:
        include: health,metrics,prometheus
```

This issue affects Apache DolphinScheduler: from 3.0.0 before 3.0.2.

Users are recommended to upgrade to version 3.0.2, which fixes the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-48796?

5 open source packages ship an affected version, including apache-dolphinscheduler and org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-dolphinscheduler` | PyPI | From 3.0.0 | 3.0.2 |
| `apache-dolphinscheduler` | PyPI | From 3.0.0 | 3.0.2 |
| `apache-dolphinscheduler` | PyPI | From 3.0.0 | 3.0.2 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 3.0.0 | 3.0.2 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 3.0.0 | 3.0.2 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2023-48796?

Upgrade apache-dolphinscheduler to 3.0.2 or later.

## Is CVE-2023-48796 being exploited?

There is no known exploitation of CVE-2023-48796 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45875](https://insights.sbomify.com/CVE-2022-45875/): Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48796 and fix it if it is affected.

What it is: CVE-2023-48796 is a high-severity vulnerability in Apache DolphinScheduler, published on 24 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48796 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-dolphinscheduler (PyPI): affected from 3.0.0; fixed in 3.0.2
- apache-dolphinscheduler (PyPI): affected from 3.0.0; fixed in 3.0.2
- apache-dolphinscheduler (PyPI): affected from 3.0.0; fixed in 3.0.2
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 3.0.0; fixed in 3.0.2
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 3.0.0; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48796/ (Markdown: https://insights.sbomify.com/CVE-2023-48796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48796
- OSV: https://osv.dev/vulnerability/CVE-2023-48796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48796/
Summaries are generated and may contain mistakes; the official description above is the record.
