# CVE-2023-48910: Microcks contains a Server-Side Request Forgery (SSRF) via the component /jobs and /artifact/download

> Attackers can exploit SSRF in Microcks to access internal network resources and sensitive information via crafted GET requests.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2023
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-gqj2-324p-vx73

## What is CVE-2023-48910?

CVE-2023-48910 is a critical server-side request forgery vulnerability in n/a, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Microcks up to 1.17.1 was discovered to contain a Server-Side Request Forgery (SSRF) via the component /jobs and /artifact/download. This vulnerability allows attackers to access network resources and sensitive information via a crafted GET request.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-48910?

2 open source packages ship an affected version, including io.github.microcks:microcks. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.github.microcks:microcks` | Maven | All versions | 1.17.1 |
| `io.github.microcks:microcks` | Maven | All versions | 1.17.1 |

Products: Microcks Microcks.

## How do I fix CVE-2023-48910?

Upgrade io.github.microcks:microcks to 1.17.1 or later.

## Is CVE-2023-48910 being exploited?

There is no known exploitation of CVE-2023-48910 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-44076](https://insights.sbomify.com/CVE-2024-44076/): Microcks's POST /api/import and POST /api/export endpoints allow non-administrator access (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-48910 and fix it if it is affected.

What it is: CVE-2023-48910 is a critical server-side request forgery vulnerability in n/a, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-48910 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.github.microcks:microcks (Maven): affected all versions; fixed in 1.17.1
- io.github.microcks:microcks (Maven): affected all versions; fixed in 1.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-48910/ (Markdown: https://insights.sbomify.com/CVE-2023-48910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-48910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-48910
- OSV: https://osv.dev/vulnerability/CVE-2023-48910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-48910/
Summaries are generated and may contain mistakes; the official description above is the record.
