CVE-2023-49070 Pre-auth RCE in Apache Ofbiz 18.12.09 due to XML-RPC still present
Attackers can execute arbitrary code remotely without authentication due to the presence of an unmaintained XML-RPC component in Apache OFBiz.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-49070?
CVE-2023-49070 is a critical code injection vulnerability in Apache Ofbiz, published on 5 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Pre-auth RCE in Apache Ofbiz 18.12.09.
It's due to XML-RPC no longer maintained still present. This issue affects Apache OFBiz: before 18.12.10. Users are recommended to upgrade to version 18.12.10
Weakness: CWE-94
Which versions are affected by CVE-2023-49070?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2023-49070?
No fix has been published for CVE-2023-49070 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-49070 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49070 exists.
Public exploit code: 1 Metasploit module, 1 Nuclei template and 7 proofs of concept on GitHub.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-9rm6-p86c-42xm.