# CVE-2023-49075: Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls

> Authenticated users can bypass two-factor authentication in non-admin security firewalls, allowing unauthorized access without second-factor verification.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-9wwg-r3c7-4vfg

## What is CVE-2023-49075?

CVE-2023-49075 is a high-severity vulnerability in pimcore admin-ui-classic-bundle, published on 28 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Admin Classic Bundle provides a Backend UI for Pimcore. `AdminBundle\Security\PimcoreUserTwoFactorCondition` introduced in v11 disable the two factor authentication for all non-admin security firewalls. An authenticated user can access the system without having to provide the two factor credentials. This issue has been patched in version 1.2.2.

Weakness: CWE-308 (Use of Single-factor Authentication)

## Which versions are affected by CVE-2023-49075?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.2 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.2 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2023-49075?

Upgrade pimcore/admin-ui-classic-bundle to 1.2.2 or later.

## Is CVE-2023-49075 being exploited?

There is no known exploitation of CVE-2023-49075 in the wild and no public exploit code.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)
- [CVE-2024-24822](https://insights.sbomify.com/CVE-2024-24822/): Pimcore Admin Classic Bundle permissions are not getting checked when working with tags (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49075 and fix it if it is affected.

What it is: CVE-2023-49075 is a high-severity vulnerability in pimcore admin-ui-classic-bundle, published on 28 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-49075 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.2
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49075/ (Markdown: https://insights.sbomify.com/CVE-2023-49075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49075
- OSV: https://osv.dev/vulnerability/CVE-2023-49075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49075/
Summaries are generated and may contain mistakes; the official description above is the record.
