# CVE-2023-49080: Jupyter Server errors include tracebacks with path information

> Authenticated users can view server file paths in error tracebacks, potentially revealing internal directory structures.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-49080, GHSA-h56g-gq9v-vc8r, PYSEC-2023-272, UBUNTU-CVE-2023-49080, openSUSE-SU-2024:13489-1

## What is CVE-2023-49080?

CVE-2023-49080 is a low-severity vulnerability in jupyter-server jupyter_server, published on 4 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications like Jupyter notebook, JupyterLab, and Voila. Unhandled errors in API requests coming from an authenticated user include traceback information, which can include path information. There is no known mechanism by which to trigger these errors without authentication, so the paths revealed are not considered particularly sensitive, given that the requesting user has arbitrary execution permissions already in the same environment. A fix has been introduced in commit `0056c3aa52` which no longer includes traceback information in JSON error responses. For compatibility, the traceback field is present, but always empty. This commit has been included in version 2.11.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-49080?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 2.11.2 |
| `jupyter-server` | PyPI | All versions | 2.11.2 |
| `jupyter-server` | PyPI | All versions | 2.11.2 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2023-49080?

Upgrade jupyter-server to 2.11.2 or later.

## Is CVE-2023-49080 being exploited?

There is no known exploitation of CVE-2023-49080 in the wild and no public exploit code.

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-35397](https://insights.sbomify.com/CVE-2026-35397/): jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix (high 7.6)
- [CVE-2026-40110](https://insights.sbomify.com/CVE-2026-40110/): jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat (high 7.6)
- [CVE-2026-40934](https://insights.sbomify.com/CVE-2026-40934/): jupyter-server authentication cookies remain valid after password reset due to static cookie secret (high 7.6)
- [CVE-2024-35178](https://insights.sbomify.com/CVE-2024-35178/): Jupyter server on Windows discloses Windows user password hash (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49080 and fix it if it is affected.

What it is: CVE-2023-49080 is a low-severity vulnerability in jupyter-server jupyter_server, published on 4 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-49080 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 2.11.2
- jupyter-server (PyPI): affected all versions; fixed in 2.11.2
- jupyter-server (PyPI): affected all versions; fixed in 2.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49080/ (Markdown: https://insights.sbomify.com/CVE-2023-49080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49080
- OSV: https://osv.dev/vulnerability/CVE-2023-49080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49080/
Summaries are generated and may contain mistakes; the official description above is the record.
