CVE-2023-49081 aiohttp's ClientSession is vulnerable to CRLF injection via version
Attackers controlling HTTP version can inject CRLF to modify requests or create new ones in aiohttp ClientSession.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-49081?
CVE-2023-49081 is a high-severity vulnerability in aio-libs aiohttp, published on 30 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Improper validation made it possible for an attacker to modify the HTTP request (e.g. to insert a new header) or create a new HTTP request if the attacker controls the HTTP version. The vulnerability only occurs if the attacker can control the HTTP version of the request. This issue has been patched in version 3.9.0.
Weakness: CWE-20
Which versions are affected by CVE-2023-49081?
3 open source packages ship an affected version, including aiohttp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
aiohttp PyPI | All versions | 3.9.0 |
aiohttp PyPI | All versions | 3.9.0 |
aiohttp PyPI | All versions | 3.9.0 |
Linux distribution packages (8)
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP1 | All versions | 3.6.0-150100.3.15.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP2 | All versions | 3.6.0-150100.3.15.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 3.6.0-150100.3.15.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.6.0-150100.3.15.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 3.6.0-150100.3.15.1 |
python-aiohttp SUSE:Linux Enterprise Module for Python 3 15 SP5 | All versions | 3.8.5-150400.10.8.1 |
python-aiohttp openSUSE:Leap 15.5 | All versions | 3.6.0-150100.3.15.1 |
python-aiohttp openSUSE:Leap 15.5 | All versions | 3.8.5-150400.10.8.1 |
Products include Aiohttp Aiohttp.
How do I fix CVE-2023-49081?
Upgrade aiohttp to 3.9.0 or later.
Is CVE-2023-49081 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49081 exists.
Other vulnerabilities in aio-libs aiohttp
- CVE-2024-52303 aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method
- CVE-2025-69223 AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb
- CVE-2024-30251 Denial of service when trying to parse malformed POST requests in aiohttp
- CVE-2026-22815 AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers
- CVE-2026-54273 AIOHTTP: HTTP/1 Pipelined Requests Queue Without Limit
Sources
Also known as CLSA-2026-1767917584, CLSA-2026-1769559191, CLSA-2026-1786470220, CLSA-2026-1787296163, DEBIAN-CVE-2023-49081, ECHO-8549-82cb-62d1 and 7 more.