# CVE-2023-49086: Cacti is vulnerable to cross-Site scripting (XSS) DOM

> An authorized user can execute arbitrary JavaScript in another user's browser via a DOM XSS vulnerability in Cacti's graph creation interface.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2023
- **Updated:** 4 Nov 2025
- **Also known as:** CLEANSTART-2024-HV82987, DEBIAN-CVE-2023-49086, GHSA-wc73-r2vw-59pr, UBUNTU-CVE-2023-49086

## What is CVE-2023-49086?

CVE-2023-49086 is a medium-severity cross-site scripting vulnerability in Cacti Cacti, published on 21 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-49086?

It affects 1 product.


Products: Cacti Cacti.

## How do I fix CVE-2023-49086?

Upgrade to a fixed version.

## Is CVE-2023-49086 being exploited?

There is no known exploitation of CVE-2023-49086 in the wild and no public exploit code.

## Other vulnerabilities in Cacti Cacti

- [CVE-2022-46169](https://insights.sbomify.com/CVE-2022-46169/): Cacti Command Injection (critical 9.8, exploited in the wild)
- [CVE-2026-39893](https://insights.sbomify.com/CVE-2026-39893/): Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php (critical 9.8)
- [CVE-2026-39938](https://insights.sbomify.com/CVE-2026-39938/): Cacti: Unauthenticated RCE on Graph Image (critical 9.8)
- [CVE-2026-39955](https://insights.sbomify.com/CVE-2026-39955/): Cacti has Pre-Authentication SQL Injection via unanchored FILTER_VALIDATE_REGEXP in graph_view.php (critical 9.8)
- [CVE-2023-39361](https://insights.sbomify.com/CVE-2023-39361/): Unauthenticated SQL Injection in graph_view.php in Cacti (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49086 and fix it if it is affected.

What it is: CVE-2023-49086 is a medium-severity cross-site scripting vulnerability in Cacti Cacti, published on 21 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-49086 in the wild and no public exploit code.

Affected product: Cacti Cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49086/ (Markdown: https://insights.sbomify.com/CVE-2023-49086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49086
- OSV: https://osv.dev/vulnerability/CVE-2023-49086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49086/
Summaries are generated and may contain mistakes; the official description above is the record.
