CVE-2023-49099 Discourse secure uploads accessible to guests even when login is required

Low 3.1 Published Updated

Guest users can access secure upload URLs in Discourse forums even when login is required, exposing private data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-49099?

CVE-2023-49099 is a low-severity missing authorization vulnerability in Discourse Discourse, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Discourse is a platform for community discussion. Under very specific circumstances, secure upload URLs associated with posts can be accessed by guest users even when login is required. This vulnerability has been patched in 3.2.0.beta4 and 3.1.4.

Weakness: CWE-284

Which versions are affected by CVE-2023-49099?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.1.4

Products include Discourse Discourse.

How do I fix CVE-2023-49099?

Upgrade discourse to 3.1.4 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-49099 being exploited?

There is no known exploitation of CVE-2023-49099 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-49099, GHSA-j67x-x6mq-pwv4.

Is CVE-2023-49099 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free