CVE-2023-4912 Allocation of Resources Without Limits or Throttling in GitLab

Low 2.6 Published Updated

An attacker can cause a client-side denial of service in GitLab by submitting maliciously crafted mermaid diagram input.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-4912?

CVE-2023-4912 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 1 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 10.5 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for an attacker to cause a client-side denial of service using malicious crafted mermaid diagram input.

Weakness: CWE-770

Which versions are affected by CVE-2023-4912?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.5.016.4.3, 16.5.3, 16.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-4912?

Upgrade gitlab to a fixed version for your release line: 16.4.3, 16.5.3 or 16.6.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-4912 being exploited?

There is no known exploitation of CVE-2023-4912 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-4912, GHSA-cqvh-4wv3-g3cj.

Is CVE-2023-4912 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free