# CVE-2023-4914: Relative Path Traversal in cecilapp/cecil

> An attacker can exploit relative path traversal in Cecil to read arbitrary files from the server.

- **Severity:** Medium 5.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-q8hr-4w58-985p

## What is CVE-2023-4914?

CVE-2023-4914 is a medium-severity path traversal vulnerability in cecilapp/cecil, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Relative Path Traversal in GitHub repository cecilapp/cecil prior to 7.47.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2023-4914?

2 open source packages ship an affected version, including cecil/cecil. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cecil/cecil` | Packagist | All versions | 7.47.1 |
| `cecil/cecil` | Packagist | All versions | 7.47.1 |

Products: Cecil Cecil.

## How do I fix CVE-2023-4914?

Upgrade cecil/cecil to 7.47.1 or later.

## Is CVE-2023-4914 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4914 exists.

## Other vulnerabilities in cecilapp/cecil

- [CVE-2023-4913](https://insights.sbomify.com/CVE-2023-4913/): Cross-site Scripting (XSS) - Reflected in cecilapp/cecil (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4914 and fix it if it is affected.

What it is: CVE-2023-4914 is a medium-severity path traversal vulnerability in cecilapp/cecil, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4914 exists.

Affected packages and fixed versions:
- cecil/cecil (Packagist): affected all versions; fixed in 7.47.1
- cecil/cecil (Packagist): affected all versions; fixed in 7.47.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4914/ (Markdown: https://insights.sbomify.com/CVE-2023-4914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4914
- OSV: https://osv.dev/vulnerability/CVE-2023-4914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4914/
Summaries are generated and may contain mistakes; the official description above is the record.
