{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.nifi:nifi-jolt-transform-json-ui and nifi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49145 in the wild and no public exploit code.","fix":"Upgrade org.apache.nifi:nifi-jolt-transform-json-ui to 1.24.0 or later.","what":"CVE-2023-49145 is a high-severity cross-site scripting vulnerability in Apache Nifi, published on 27 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-49145 and fix it if it is affected.\n\nWhat it is: CVE-2023-49145 is a high-severity cross-site scripting vulnerability in Apache Nifi, published on 27 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-49145 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.nifi:nifi-jolt-transform-json-ui (Maven): affected all versions; fixed in 1.24.0\n- org.apache.nifi:nifi-jolt-transform-json-ui (Maven): affected all versions; fixed in 1.24.0\n- nifi (Bitnami): affected from 0.7.0; fixed in 1.24.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49145/ (Markdown: https://insights.sbomify.com/CVE-2023-49145/index.md)","id":"CVE-2023-49145","markdown":"https://insights.sbomify.com/CVE-2023-49145/index.md","name":"CVE-2023-49145","record":{"aliases":["BIT-nifi-2023-49145","GHSA-68pr-6fjc-wmgm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache NiFi","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary JavaScript via a crafted URL in the JoltTransformJSON processor interface, potentially leading to session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":7.9,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary\nJavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache NiFi: Improper Neutralization of Input in Advanced User Interface for Jolt","id":"CVE-2023-49145","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:nifi","products":["apache:nifi"],"type":"xss","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Cross-site Scripting in DOMSanitizer","id":"CVE-2023-49146"},"packages":[{"ecosystem":"Bitnami","fixed":["1.24.0"],"introduced":["0.7.0"],"last_affected":[],"package":"nifi","purl":"pkg:bitnami/nifi","source":"BIT-nifi-2023-49145"},{"ecosystem":"Maven","fixed":["1.24.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.nifi:nifi-jolt-transform-json-ui","purl":null,"source":"GHSA-68pr-6fjc-wmgm"},{"ecosystem":"Maven","fixed":["1.24.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.nifi:nifi-jolt-transform-json-ui","purl":"pkg:maven/org.apache.nifi/nifi-jolt-transform-json-ui","source":"GHSA-68pr-6fjc-wmgm"}],"prev":{"headline":"Information disclosure in Intel(R) Server Platforms","id":"CVE-2023-49144"},"products":["Apache NiFi"],"published":"2023-11-27","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can execute arbitrary JavaScript via a crafted URL in the JoltTransformJSON processor interface, potentially leading to session hijacking.","url":"https://insights.sbomify.com/CVE-2023-49145/"}