# CVE-2023-49145: Apache NiFi: Improper Neutralization of Input in Advanced User Interface for Jolt

> Authenticated users can execute arbitrary JavaScript via a crafted URL in the JoltTransformJSON processor interface, potentially leading to session hijacking.

- **Severity:** High 7.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Nov 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-nifi-2023-49145, GHSA-68pr-6fjc-wmgm

## What is CVE-2023-49145?

CVE-2023-49145 is a high-severity cross-site scripting vulnerability in Apache Nifi, published on 27 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary
JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-49145?

3 open source packages ship an affected version, including org.apache.nifi:nifi-jolt-transform-json-ui and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-jolt-transform-json-ui` | Maven | All versions | 1.24.0 |
| `org.apache.nifi:nifi-jolt-transform-json-ui` | Maven | All versions | 1.24.0 |
| `nifi` | Bitnami | From 0.7.0 | 1.24.0 |

Products: Apache Nifi.

## How do I fix CVE-2023-49145?

Upgrade org.apache.nifi:nifi-jolt-transform-json-ui to 1.24.0 or later.

## Is CVE-2023-49145 being exploited?

There is no known exploitation of CVE-2023-49145 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49145 and fix it if it is affected.

What it is: CVE-2023-49145 is a high-severity cross-site scripting vulnerability in Apache Nifi, published on 27 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-49145 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-jolt-transform-json-ui (Maven): affected all versions; fixed in 1.24.0
- org.apache.nifi:nifi-jolt-transform-json-ui (Maven): affected all versions; fixed in 1.24.0
- nifi (Bitnami): affected from 0.7.0; fixed in 1.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49145/ (Markdown: https://insights.sbomify.com/CVE-2023-49145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49145
- OSV: https://osv.dev/vulnerability/CVE-2023-49145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49145/
Summaries are generated and may contain mistakes; the official description above is the record.
