CVE-2023-4919 iframe <= 4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'iframe' Shortcode

Medium 6.4 Published Updated

Authenticated attackers can inject arbitrary web scripts via the iframe shortcode, leading to stored XSS execution on victim pages.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-4919?

CVE-2023-4919 is a medium-severity cross-site scripting vulnerability in webvitaly iframe, published on 20 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `iframe` shortcode in versions up to, and including, 4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permission and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 4.6 and fully patched in version 4.7.

Weakness: CWE-79

Which versions are affected by CVE-2023-4919?

It affects 1 product.

Products include Iframe Project Iframe.

How do I fix CVE-2023-4919?

No fix has been published for CVE-2023-4919 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-4919 being exploited?

There is no known exploitation of CVE-2023-4919 in the wild and no public exploit code.

Sources

Also known as GHSA-fhx9-p329-4x23.

Is CVE-2023-4919 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free