# CVE-2023-49198: Apache SeaTunnel Web: Arbitrary file read vulnerability

> Attackers can read arbitrary files on the MySQL server by manipulating connection parameters in Apache SeaTunnel Web.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2024
- **Updated:** 23 Aug 2024
- **Also known as:** GHSA-8m84-h9hh-3cfh

## What is CVE-2023-49198?

CVE-2023-49198 is a high-severity path traversal vulnerability in Apache SeaTunnel Web, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mysql security vulnerability in Apache SeaTunnel.

Attackers can read files on the MySQL server by modifying the information in the MySQL URL

 allowLoadLocalInfile=true&allowUrlInLocalInfile=true&allowLoadLocalInfileInPath=/&maxAllowedPacket=655360
This issue affects Apache SeaTunnel: 1.0.0.

Users are recommended to upgrade to version [1.0.1], which fixes the issue.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2023-49198?

2 open source packages ship an affected version, including org.apache.seatunnel:seatunnel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.seatunnel:seatunnel` | Maven | From 1.0.0 | 1.0.1 |
| `org.apache.seatunnel:seatunnel` | Maven | From 1.0.0 | 1.0.1 |

Products: Apache Seatunnel.

## How do I fix CVE-2023-49198?

Upgrade org.apache.seatunnel:seatunnel to 1.0.1 or later.

## Is CVE-2023-49198 being exploited?

There is no known exploitation of CVE-2023-49198 in the wild and no public exploit code.

## Other vulnerabilities in Apache SeaTunnel Web

- [CVE-2023-48396](https://insights.sbomify.com/CVE-2023-48396/): Apache SeaTunnel Web: Authentication bypass (critical 9.1)
- [CVE-2025-32896](https://insights.sbomify.com/CVE-2025-32896/): Apache SeaTunnel: Unauthenticated insecure access (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49198 and fix it if it is affected.

What it is: CVE-2023-49198 is a high-severity path traversal vulnerability in Apache SeaTunnel Web, published on 21 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49198 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.seatunnel:seatunnel (Maven): affected from 1.0.0; fixed in 1.0.1
- org.apache.seatunnel:seatunnel (Maven): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49198/ (Markdown: https://insights.sbomify.com/CVE-2023-49198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49198
- OSV: https://osv.dev/vulnerability/CVE-2023-49198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49198/
Summaries are generated and may contain mistakes; the official description above is the record.
