{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49213 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-49213 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-49213 is a high-severity command injection vulnerability in n/a, published on 23 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49213 and fix it if it is affected.\n\nWhat it is: CVE-2023-49213 is a high-severity command injection vulnerability in n/a, published on 23 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-49213 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49213/ (Markdown: https://insights.sbomify.com/CVE-2023-49213/index.md)","id":"CVE-2023-49213","markdown":"https://insights.sbomify.com/CVE-2023-49213/index.md","name":"CVE-2023-49213","record":{"aliases":["GHSA-33rj-7vx9-p22p"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PowerShell Universal","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary commands via crafted HTTP requests in Ironman PowerShell Universal if param blocks are used.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"powershell_universal","vendor":"ironmansoftware"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP requests if a param block is used, due to invalid sanitization of input strings. The fixed versions are 3.10.2, 4.1.10, and 4.2.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Command injection in n/a","id":"CVE-2023-49213","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"Code injection in n/a","id":"CVE-2023-49214"},"packages":[],"prev":{"headline":"openssl npm package vulnerable to command execution","id":"CVE-2023-49210"},"products":["n/a"],"published":"2023-11-23","related":[{"cvss_score":8.8,"headline":"Privilege escalation in n/a","id":"CVE-2022-45183","kev_date_added":null,"published":"2022-11-14"},{"cvss_score":8.3,"headline":"Missing authorization in PowerShell Universal","id":"CVE-2026-4064","kev_date_added":null,"published":"2026-03-17"},{"cvss_score":7.2,"headline":"Path traversal in n/a","id":"CVE-2022-45184","kev_date_added":null,"published":"2022-11-14"},{"cvss_score":6.1,"headline":"Cross-site scripting in PowerShell Universal","id":"CVE-2026-0618","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":5.5,"headline":"Denial of service in PowerShell Universal","id":"CVE-2026-3563","kev_date_added":null,"published":"2026-03-17"},{"cvss_score":5.5,"headline":"Hardcoded credentials in PowerShell Universal","id":"CVE-2026-3277","kev_date_added":null,"published":"2026-02-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via crafted HTTP requests in Ironman PowerShell Universal if param blocks are used.","url":"https://insights.sbomify.com/CVE-2023-49213/"}