CVE-2023-49250 Apache DolphinScheduler: Insecure TLS TrustManager used in HttpUtil
An insecure TLS TrustManager allows attackers to perform Man-in-the-Middle attacks on outgoing HTTPS connections, potentially intercepting or modifying data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-49250?
CVE-2023-49250 is a high-severity vulnerability in Apache DolphinScheduler, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Because the HttpUtils class did not verify certificates, an attacker that could perform a Man-in-the-Middle (MITM) attack on outgoing https connections could impersonate the server.
This issue affects Apache DolphinScheduler: before 3.2.0.
Users are recommended to upgrade to version 3.2.1, which fixes the issue.
Weakness: CWE-295
Which versions are affected by CVE-2023-49250?
2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.dolphinscheduler:dolphinscheduler Maven | All versions | 3.2.1 |
org.apache.dolphinscheduler:dolphinscheduler Maven | All versions | 3.2.1 |
Products include Apache Dolphinscheduler.
How do I fix CVE-2023-49250?
Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.2.1 or later.
Is CVE-2023-49250 being exploited?
There is no known exploitation of CVE-2023-49250 in the wild and no public exploit code.
Other vulnerabilities in Apache DolphinScheduler
- CVE-2024-43166 Apache DolphinScheduler Incorrect Default Permissions Vulnerability
- CVE-2024-43202 Apache DolphinScheduler: Remote Code Execution Vulnerability
- CVE-2023-49109 Remote Code Execution in Apache Dolphinscheduler
- CVE-2022-45875 Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
- CVE-2022-45462 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
Sources
Also known as GHSA-37gx-jqx9-fwmg.