{"answers":{"affected":"2 open source packages ship an affected version, including uptime-kuma. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49276 in the wild and no public exploit code.","fix":"Upgrade uptime-kuma to 1.23.7 or later.","what":"CVE-2023-49276 is a medium-severity cross-site scripting vulnerability in louislam uptime-kuma, published on 1 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-49276 and fix it if it is affected.\n\nWhat it is: CVE-2023-49276 is a medium-severity cross-site scripting vulnerability in louislam uptime-kuma, published on 1 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-49276 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uptime-kuma (npm): affected from 1.20.0; fixed in 1.23.7\n- uptime-kuma (npm): affected from 1.20.0; fixed in 1.23.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49276/ (Markdown: https://insights.sbomify.com/CVE-2023-49276/index.md)","id":"CVE-2023-49276","markdown":"https://insights.sbomify.com/CVE-2023-49276/index.md","name":"CVE-2023-49276","record":{"aliases":["GHSA-v4v2-8h88-65qj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Uptime Kuma monitoring tool","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via unsanitized Google Analytics IDs in the custom status interface, leading to XSS attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"uptime_kuma","vendor":"uptime.kuma"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Uptime Kuma is an open source self-hosted monitoring tool. In affected versions the Google Analytics element in vulnerable to Attribute Injection leading to Cross-Site-Scripting (XSS). Since the custom status interface can set an independent Google Analytics ID and the template has not been sanitized, there is an attribute injection vulnerability here, which can lead to XSS attacks. This vulnerability has been addressed in commit `f28dccf4e` which is included in release version 1.23.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Attribute Injection leading to XSS(Cross-Site-Scripting) in uptime-kuma","id":"CVE-2023-49276","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Reflected Cross-site Scripting Vulnerability in dpaste","id":"CVE-2023-49277"},"packages":[{"ecosystem":"npm","fixed":["1.23.7"],"introduced":["1.20.0"],"last_affected":[],"package":"uptime-kuma","purl":null,"source":"GHSA-v4v2-8h88-65qj"},{"ecosystem":"npm","fixed":["1.23.7"],"introduced":["1.20.0"],"last_affected":[],"package":"uptime-kuma","purl":"pkg:npm/uptime-kuma","source":"GHSA-v4v2-8h88-65qj"}],"prev":{"headline":"Wazuh vulnerable to NULL Pointer Dereference in wazuh-analysisd","id":"CVE-2023-49275"},"products":["uptime-kuma"],"published":"2023-12-01","related":[{"cvss_score":6.7,"headline":"Uptime Kuma has Persistentent User Sessions","id":"CVE-2023-44400","kev_date_added":null,"published":"2023-10-09"},{"cvss_score":6.5,"headline":"Uptime Kuma: SSTI in Notification Templates Allows Arbitrary File Read (Incomplete Fix for GHSA-vffh-c9pq-4crh)","id":"CVE-2026-33130","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":5.3,"headline":"Uptime Kuma is Missing Authorization Checks on Ping Badge Endpoint, Leaks Ping times of monitors without needing to be on a status page","id":"CVE-2026-32230","kev_date_added":null,"published":"2026-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["louislam"]},"summary":"Attackers can inject malicious scripts via unsanitized Google Analytics IDs in the custom status interface, leading to XSS attacks.","url":"https://insights.sbomify.com/CVE-2023-49276/"}