{"answers":{"affected":"3 open source packages ship an affected version, including dpaste and Dpaste. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49277 in the wild and no public exploit code.","fix":"Upgrade dpaste to 3.8 or later.","what":"CVE-2023-49277 is a high-severity cross-site scripting vulnerability in DarrenOfficial dpaste, published on 1 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-49277 and fix it if it is affected.\n\nWhat it is: CVE-2023-49277 is a high-severity cross-site scripting vulnerability in DarrenOfficial dpaste, published on 1 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-49277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dpaste (PyPI): affected all versions; fixed in 3.8\n- dpaste (PyPI): affected all versions; fixed in 3.8\n- Dpaste (PyPI): affected all versions; fixed in 3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49277/ (Markdown: https://insights.sbomify.com/CVE-2023-49277/index.md)","id":"CVE-2023-49277","markdown":"https://insights.sbomify.com/CVE-2023-49277/index.md","name":"CVE-2023-49277","record":{"aliases":["GHSA-r8j9-5cj7-cv39","PYSEC-2026-1317"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python pastebin application","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in user browsers via the expires parameter, leading to data theft or unauthorized access.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dpaste","vendor":"darrennathanael"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"dpaste is an open source pastebin application written in Python using the Django framework. A security vulnerability has been identified in the expires parameter of the dpaste API, allowing for a POST Reflected XSS attack. This vulnerability can be exploited by an attacker to execute arbitrary JavaScript code in the context of a user's browser, potentially leading to unauthorized access, data theft, or other malicious activities. Users are strongly advised to upgrade to dpaste release v3.8 or later versions, as dpaste versions older than v3.8 are susceptible to the identified security vulnerability. No known workarounds have been identified, and applying the patch is the most effective way to remediate the vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected Cross-site Scripting Vulnerability in dpaste","id":"CVE-2023-49277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Umbraco CMS brute force exploit can be used to collect valid usernames","id":"CVE-2023-49278"},"packages":[{"ecosystem":"PyPI","fixed":["3.8"],"introduced":["0"],"last_affected":[],"package":"Dpaste","purl":null,"source":"GHSA-r8j9-5cj7-cv39"},{"ecosystem":"PyPI","fixed":["3.8"],"introduced":["0"],"last_affected":[],"package":"dpaste","purl":"pkg:pypi/dpaste","source":"GHSA-r8j9-5cj7-cv39"},{"ecosystem":"PyPI","fixed":["3.8"],"introduced":["0"],"last_affected":[],"package":"dpaste","purl":"pkg:pypi/dpaste","source":"PYSEC-2026-1317"}],"prev":{"headline":"Attribute Injection leading to XSS(Cross-Site-Scripting) in uptime-kuma","id":"CVE-2023-49276"},"products":["dpaste"],"published":"2023-12-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-11","vendors":["DarrenOfficial"]},"summary":"Attackers can execute arbitrary JavaScript in user browsers via the expires parameter, leading to data theft or unauthorized access.","url":"https://insights.sbomify.com/CVE-2023-49277/"}