# CVE-2023-49280: Data leak of password hash through xwiki change request

> Attackers can leak password hashes by editing user profiles via Change Request and downloading the resulting XML export.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2023
- **Updated:** 27 Nov 2024
- **Also known as:** GHSA-2fr7-cc7p-p45q

## What is CVE-2023-49280?

CVE-2023-49280 is a high-severity vulnerability in xwiki-contrib application-changerequest, published on 4 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Change Request is an XWiki application allowing to request changes on a wiki without publishing directly the changes. Change request allows to edit any page by default, and the changes are then exported in an XML file that anyone can download. So it's possible for an attacker to obtain password hash of users by performing an edit on the user profiles and then downloading the XML file that has been created. This is also true for any document that might contain password field and that a user can view.
This vulnerability impacts all version of Change Request, but the impact depends on the rights that has been set on the wiki since it requires for the user to have the Change request right (allowed by default) and view rights on the page to target. This issue cannot be easily exploited in an automated way. The patch consists in denying to users the right of editing pages that contains a password field with change request. It means that already existing change request for those pages won't be removed by the patch, administrators needs to take care of it. The patch is provided in Change Request 1.10, administrators should upgrade immediately. It's possible to workaround the vulnerability by denying manually the Change request right on some spaces, such as XWiki space which will include any user profile by default.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2023-49280?

2 open source packages ship an affected version, including org.xwiki.contrib.changerequest:application-changerequest-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib.changerequest:application-changerequest-default` | Maven | From 0.1 | 1.10 |
| `org.xwiki.contrib.changerequest:application-changerequest-default` | Maven | From 0.1 | 1.10 |

Products: Xwiki Change Request.

## How do I fix CVE-2023-49280?

Upgrade org.xwiki.contrib.changerequest:application-changerequest-default to 1.10 or later.

## Is CVE-2023-49280 being exploited?

There is no known exploitation of CVE-2023-49280 in the wild and no public exploit code.

## Other vulnerabilities in xwiki-contrib application-changerequest

- [CVE-2023-45138](https://insights.sbomify.com/CVE-2023-45138/): Change Request Application vulnerable to XSS and remote code execution through change request title (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49280 and fix it if it is affected.

What it is: CVE-2023-49280 is a high-severity vulnerability in xwiki-contrib application-changerequest, published on 4 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49280 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.contrib.changerequest:application-changerequest-default (Maven): affected from 0.1; fixed in 1.10
- org.xwiki.contrib.changerequest:application-changerequest-default (Maven): affected from 0.1; fixed in 1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49280/ (Markdown: https://insights.sbomify.com/CVE-2023-49280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49280
- OSV: https://osv.dev/vulnerability/CVE-2023-49280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49280/
Summaries are generated and may contain mistakes; the official description above is the record.
