{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49288 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-49288 is a high-severity use after free vulnerability in Squid-Cache Squid, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49288 and fix it if it is affected.\n\nWhat it is: CVE-2023-49288 is a high-severity use after free vulnerability in Squid-Cache Squid, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-49288 in the wild and no public exploit code.\n\nAffected product: Squid-Cache Squid. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49288/ (Markdown: https://insights.sbomify.com/CVE-2023-49288/index.md)","id":"CVE-2023-49288","markdown":"https://insights.sbomify.com/CVE-2023-49288/index.md","name":"CVE-2023-49288","record":{"aliases":["ALPINE-CVE-2023-49288","AZL-32073","CLSA-2024-1714462008","CLSA-2024-1716272474","CLSA-2025-1741034026","CLSA-2026-1777539711","CLSA-2026-1777539902","CLSA-2026-1777544744","DEBIAN-CVE-2023-49288","GHSA-rj5h-46j6-q2g5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Squid caching proxy","requires_auth":"none","summary":"A use-after-free bug in Squid's collapsed forwarding feature allows attackers to cause a denial of service.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"squid","vendor":"squid-cache"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with \"collapsed_forwarding on\" are vulnerable. Configurations with \"collapsed_forwarding off\" or without a \"collapsed_forwarding\" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in HTTP Collapsed Forwarding in Squid","id":"CVE-2023-49288","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"squid-cache:squid","products":["squid-cache:squid"],"type":"use_after_free","year":"2023"},"n_packages":0,"n_references":4,"next":{"headline":"Cross-site Scripting in Ajax.NET Professional","id":"CVE-2023-49289"},"packages":[],"prev":{"headline":"Buffer overflow vulnerabilities in tinydir","id":"CVE-2023-49287"},"products":["squid"],"published":"2023-12-04","related":[{"cvss_score":10,"headline":"Squid vulnerable to information disclosure via authentication credential leakage in error handling","id":"CVE-2025-62168","kev_date_added":null,"published":"2025-10-17"},{"cvss_score":9.3,"headline":"Squid's URN Handling can lead to Buffer Overflow","id":"CVE-2025-54574","kev_date_added":null,"published":"2025-08-01"},{"cvss_score":9.2,"headline":"Squid vulnerable to Denial of Service in ICP Request handling","id":"CVE-2026-33526","kev_date_added":null,"published":"2026-03-26"},{"cvss_score":8.7,"headline":"Squid has Denial of Service in ICP Response handling","id":"CVE-2026-32748","kev_date_added":null,"published":"2026-03-26"},{"cvss_score":8.6,"headline":"SQUID-2023:10 Denial of Service in HTTP Request parsing","id":"CVE-2023-50269","kev_date_added":null,"published":"2023-12-14"},{"cvss_score":8.6,"headline":"Denial of Service in HTTP Message Processing in Squid","id":"CVE-2023-49285","kev_date_added":null,"published":"2023-12-04"},{"cvss_score":8.6,"headline":"Denial of Service in Helper Process management","id":"CVE-2023-49286","kev_date_added":null,"published":"2023-12-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["squid-cache"]},"summary":"A use-after-free bug in Squid's collapsed forwarding feature allows attackers to cause a denial of service.","url":"https://insights.sbomify.com/CVE-2023-49288/"}