# CVE-2023-49288: Denial of Service in HTTP Collapsed Forwarding in Squid

> A use-after-free bug in Squid's collapsed forwarding feature allows attackers to cause a denial of service.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** ALPINE-CVE-2023-49288, AZL-32073, CLSA-2024-1714462008, CLSA-2024-1716272474, CLSA-2025-1741034026, CLSA-2026-1777539711, CLSA-2026-1777539902, CLSA-2026-1777544744, DEBIAN-CVE-2023-49288, GHSA-rj5h-46j6-q2g5

## What is CVE-2023-49288?

CVE-2023-49288 is a high-severity use after free vulnerability in Squid-Cache Squid, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with "collapsed_forwarding on" are vulnerable. Configurations with "collapsed_forwarding off" or without a "collapsed_forwarding" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2023-49288?

It affects 1 product.


Products: Squid-Cache Squid.

## How do I fix CVE-2023-49288?

Upgrade to a fixed version.

## Is CVE-2023-49288 being exploited?

There is no known exploitation of CVE-2023-49288 in the wild and no public exploit code.

## Other vulnerabilities in Squid-Cache Squid

- [CVE-2025-62168](https://insights.sbomify.com/CVE-2025-62168/): Squid vulnerable to information disclosure via authentication credential leakage in error handling (critical 10.0)
- [CVE-2025-54574](https://insights.sbomify.com/CVE-2025-54574/): Squid's URN Handling can lead to Buffer Overflow (critical 9.3)
- [CVE-2026-33526](https://insights.sbomify.com/CVE-2026-33526/): Squid vulnerable to Denial of Service in ICP Request handling (critical 9.2)
- [CVE-2026-32748](https://insights.sbomify.com/CVE-2026-32748/): Squid has Denial of Service in ICP Response handling (high 8.7)
- [CVE-2023-50269](https://insights.sbomify.com/CVE-2023-50269/): SQUID-2023:10 Denial of Service in HTTP Request parsing (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49288 and fix it if it is affected.

What it is: CVE-2023-49288 is a high-severity use after free vulnerability in Squid-Cache Squid, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49288 in the wild and no public exploit code.

Affected product: Squid-Cache Squid. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49288/ (Markdown: https://insights.sbomify.com/CVE-2023-49288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49288
- OSV: https://osv.dev/vulnerability/CVE-2023-49288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49288/
Summaries are generated and may contain mistakes; the official description above is the record.
