{"answers":{"affected":"2 open source packages ship an affected version, including AjaxNetProfessional. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49289 in the wild and no public exploit code.","fix":"Upgrade AjaxNetProfessional to 21.12.22.1 or later.","what":"CVE-2023-49289 is a medium-severity cross-site scripting vulnerability in michaelschwarz Ajax.NET-Professional, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-49289 and fix it if it is affected.\n\nWhat it is: CVE-2023-49289 is a medium-severity cross-site scripting vulnerability in michaelschwarz Ajax.NET-Professional, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-49289 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- AjaxNetProfessional (NuGet): affected all versions; fixed in 21.12.22.1\n- AjaxNetProfessional (NuGet): affected all versions; fixed in 21.12.22.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49289/ (Markdown: https://insights.sbomify.com/CVE-2023-49289/index.md)","id":"CVE-2023-49289","markdown":"https://insights.sbomify.com/CVE-2023-49289/index.md","name":"CVE-2023-49289","record":{"aliases":["GHSA-8v6j-gc74-fmpp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"ASP.NET AJAX framework","requires_auth":"none","summary":"Cross-site scripting vulnerability in Ajax.NET Professional allows attackers to execute arbitrary scripts in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ajax.net_professional","vendor":"michaelschwarz"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Ajax.NET Professional (AjaxPro) is an AJAX framework for Microsoft ASP.NET which will create proxy JavaScript classes that are used on client-side to invoke methods on the web server. Affected versions of this package are vulnerable cross site scripting attacks. Releases before version 21.12.22.1 are affected. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Ajax.NET Professional","id":"CVE-2023-49289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Malicious parameters can cause a denial of service in lestrrat-go/jwx","id":"CVE-2023-49290"},"packages":[{"ecosystem":"NuGet","fixed":["21.12.22.1"],"introduced":["0"],"last_affected":[],"package":"AjaxNetProfessional","purl":null,"source":"GHSA-8v6j-gc74-fmpp"},{"ecosystem":"NuGet","fixed":["21.12.22.1"],"introduced":["0"],"last_affected":[],"package":"AjaxNetProfessional","purl":"pkg:nuget/AjaxNetProfessional","source":"GHSA-8v6j-gc74-fmpp"}],"prev":{"headline":"Denial of Service in HTTP Collapsed Forwarding in Squid","id":"CVE-2023-49288"},"products":["Ajax.NET-Professional"],"published":"2023-12-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-11","vendors":["michaelschwarz"]},"summary":"Cross-site scripting vulnerability in Ajax.NET Professional allows attackers to execute arbitrary scripts in user browsers.","url":"https://insights.sbomify.com/CVE-2023-49289/"}