{"answers":{"affected":"6 open source packages ship an affected version, including github.com/lestrrat-go/jwx and github.com/lestrrat-go/jwx/v2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49290 exists.","fix":"Upgrade github.com/lestrrat-go/jwx to 1.2.27 or later.","what":"CVE-2023-49290 is a medium-severity denial of service vulnerability in lestrrat-go jwx, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49290 and fix it if it is affected.\n\nWhat it is: CVE-2023-49290 is a medium-severity denial of service vulnerability in lestrrat-go jwx, published on 4 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49290 exists.\n\nAffected packages and fixed versions:\n- github.com/lestrrat-go/jwx (Go): affected all versions; fixed in 1.2.27\n- github.com/lestrrat-go/jwx (Go): affected all versions; fixed in 1.2.27\n- github.com/lestrrat-go/jwx (Go): affected all versions; fixed in 1.2.27\n- github.com/lestrrat-go/jwx/v2 (Go): affected all versions; fixed in 2.0.18\n- github.com/lestrrat-go/jwx/v2 (Go): affected all versions; fixed in 2.0.18\n- github.com/lestrrat-go/jwx/v2 (Go): affected all versions; fixed in 2.0.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49290/ (Markdown: https://insights.sbomify.com/CVE-2023-49290/index.md)","id":"CVE-2023-49290","markdown":"https://insights.sbomify.com/CVE-2023-49290/index.md","name":"CVE-2023-49290","record":{"aliases":["GHSA-7f9x-gw85-8grf","GO-2023-2379","MINI-2v42-w5h3-9jwf","MINI-528m-5c78-877j","MINI-8xvj-jv4h-j35x","MINI-fxcj-487f-82g9","MINI-jcp8-gc4v-x3fw","MINI-mjwv-7236-7xjj","MINI-mx5f-8qq3-8qvc","MINI-q6gf-xg3w-xp36","MINI-r3jh-6mpr-47rv","MINI-vq49-3w87-26vh","MINI-vvwv-qf49-458w","MINI-x45p-c9v5-h8x7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go JOSE library","requires_auth":"none","summary":"An attacker can cause a denial of service in the lestrrat-go/jwx library by setting an excessively high p2c parameter in JWE headers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jwx","vendor":"lestrrat-go"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"lestrrat-go/jwx is a Go module implementing various JWx (JWA/JWE/JWK/JWS/JWT, otherwise known as JOSE) technologies. A p2c parameter set too high in JWE's algorithm PBES2-* could lead to a denial of service. The JWE key management algorithms based on PBKDF2 require a JOSE Header Parameter called p2c (PBES2 Count). This parameter dictates the number of PBKDF2 iterations needed to derive a CEK wrapping key. Its primary purpose is to intentionally slow down the key derivation function, making password brute-force and dictionary attacks more resource- intensive. Therefore, if an attacker sets the p2c parameter in JWE to a very large number, it can cause a lot of computational consumption, resulting in a denial of service. This vulnerability has been addressed in commit `64f2a229b` which has been included in release version 1.2.27 and 2.0.18. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Malicious parameters can cause a denial of service in lestrrat-go/jwx","id":"CVE-2023-49290","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":6,"n_references":2,"next":{"headline":"Improper Sanitization of Branch Name Leads to Arbitrary Code Injection","id":"CVE-2023-49291"},"packages":[{"ecosystem":"Go","fixed":["1.2.27"],"introduced":["0"],"last_affected":[],"package":"github.com/lestrrat-go/jwx","purl":null,"source":"GHSA-7f9x-gw85-8grf"},{"ecosystem":"Go","fixed":["1.2.27"],"introduced":["0"],"last_affected":[],"package":"github.com/lestrrat-go/jwx","purl":"pkg:golang/github.com/lestrrat-go/jwx","source":"GHSA-7f9x-gw85-8grf"},{"ecosystem":"Go","fixed":["1.2.27"],"introduced":["0"],"last_affected":[],"package":"github.com/lestrrat-go/jwx","purl":"pkg:golang/github.com/lestrrat-go/jwx","source":"GO-2023-2379"},{"ecosystem":"Go","fixed":["2.0.18"],"introduced":["0"],"last_affected":[],"package":"github.com/lestrrat-go/jwx/v2","purl":null,"source":"GHSA-7f9x-gw85-8grf"},{"ecosystem":"Go","fixed":["2.0.18"],"introduced":["0"],"last_affected":[],"package":"github.com/lestrrat-go/jwx/v2","purl":"pkg:golang/github.com/lestrrat-go/jwx/v2","source":"GHSA-7f9x-gw85-8grf"},{"ecosystem":"Go","fixed":["2.0.18"],"introduced":["0"],"last_affected":[],"package":"github.com/lestrrat-go/jwx/v2","purl":"pkg:golang/github.com/lestrrat-go/jwx/v2","source":"GO-2023-2379"}],"prev":{"headline":"Cross-site Scripting in Ajax.NET Professional","id":"CVE-2023-49289"},"products":["jwx"],"published":"2023-12-04","related":[{"cvss_score":6.8,"headline":"JWX vulnerable to a denial of service attack using compressed JWE message","id":"CVE-2024-28122","kev_date_added":null,"published":"2024-03-09"},{"cvss_score":4.3,"headline":"Parsing JSON serialized payload without protected field can lead to segfault","id":"CVE-2024-21664","kev_date_added":null,"published":"2024-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-29","vendors":["lestrrat-go"]},"summary":"An attacker can cause a denial of service in the lestrrat-go/jwx library by setting an excessively high p2c parameter in JWE headers.","url":"https://insights.sbomify.com/CVE-2023-49290/"}