{"answers":{"affected":"5 open source packages ship an affected version, including pydrive2 and PyDrive2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49297 in the wild and no public exploit code.","fix":"Upgrade pydrive2 to 1.16.2 or later.","what":"CVE-2023-49297 is a low-severity unsafe deserialization vulnerability in iterative PyDrive2, published on 5 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-49297 and fix it if it is affected.\n\nWhat it is: CVE-2023-49297 is a low-severity unsafe deserialization vulnerability in iterative PyDrive2, published on 5 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-49297 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pydrive2 (PyPI): affected all versions; no fix listed\n- pydrive2 (PyPI): affected all versions; fixed in 1.16.2\n- pydrive2 (PyPI): affected all versions; fixed in 1.16.2\n- PyDrive2 (PyPI): affected all versions; no fix listed\n- PyDrive2 (PyPI): affected all versions; fixed in 1.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49297/ (Markdown: https://insights.sbomify.com/CVE-2023-49297/index.md)","id":"CVE-2023-49297","markdown":"https://insights.sbomify.com/CVE-2023-49297/index.md","name":"CVE-2023-49297","record":{"aliases":["GHSA-v5f6-hjmf-9mc5","PYSEC-2023-291","UBUNTU-CVE-2023-49297","openSUSE-SU-2024:13493-1","openSUSE-SU-2026:12030-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python Google Drive library","requires_auth":"none","summary":"A malicious YAML file in the working directory allows arbitrary code execution when initializing GoogleAuth in PyDrive2.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pydrive2","vendor":"iterative"}],"cvss":{"score":3.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"PyDrive2 is a wrapper library of google-api-python-client that simplifies many common Google Drive API V2 tasks. Unsafe YAML deserilization will result in arbitrary code execution. A maliciously crafted YAML file can cause arbitrary code execution if PyDrive2 is run in the same directory as it, or if it is loaded in via `LoadSettingsFile`. This is a deserilization attack that will affect any user who initializes GoogleAuth from this package while a malicious yaml file is present in the same directory. This vulnerability does not require the file to be directly loaded through the code, only present. This issue has been addressed in commit `c57355dc` which is included in release version `1.16.2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe YAML deserialization in PyDrive2","id":"CVE-2023-49297","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":6,"n_references":4,"next":{"headline":"Other in n/a","id":"CVE-2023-49298"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":[],"last_affected":[],"package":"PyDrive2","purl":null,"source":"GHSA-v5f6-hjmf-9mc5"},{"ecosystem":"PyPI","fixed":["1.16.2"],"introduced":["0"],"last_affected":[],"package":"PyDrive2","purl":null,"source":"GHSA-v5f6-hjmf-9mc5"},{"ecosystem":"PyPI","fixed":[],"introduced":[],"last_affected":[],"package":"pydrive2","purl":"pkg:pypi/pydrive2","source":"GHSA-v5f6-hjmf-9mc5"},{"ecosystem":"PyPI","fixed":["1.16.2"],"introduced":["0"],"last_affected":[],"package":"pydrive2","purl":"pkg:pypi/pydrive2","source":"GHSA-v5f6-hjmf-9mc5"},{"ecosystem":"PyPI","fixed":["1.16.2"],"introduced":["0"],"last_affected":[],"package":"pydrive2","purl":"pkg:pypi/pydrive2","source":"PYSEC-2023-291"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.18.1-2.4"],"introduced":["0"],"last_affected":[],"package":"python-pydrive2","purl":"pkg:rpm/opensuse/python-pydrive2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12030-1"}],"prev":{"headline":"Arduino Create Agent vulnerable to Reflected Cross-Site Scripting","id":"CVE-2023-49296"},"products":["PyDrive2"],"published":"2023-12-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["iterative"]},"summary":"A malicious YAML file in the working directory allows arbitrary code execution when initializing GoogleAuth in PyDrive2.","url":"https://insights.sbomify.com/CVE-2023-49297/"}