{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler-master. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49299 in the wild and no public exploit code.","fix":"Upgrade org.apache.dolphinscheduler:dolphinscheduler-master to 3.1.9 or later.","what":"CVE-2023-49299 is a high-severity code injection vulnerability in Apache DolphinScheduler, published on 30 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49299 and fix it if it is affected.\n\nWhat it is: CVE-2023-49299 is a high-severity code injection vulnerability in Apache DolphinScheduler, published on 30 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-49299 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.dolphinscheduler:dolphinscheduler-master (Maven): affected all versions; fixed in 3.1.9\n- org.apache.dolphinscheduler:dolphinscheduler-master (Maven): affected all versions; fixed in 3.1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49299/ (Markdown: https://insights.sbomify.com/CVE-2023-49299/index.md)","id":"CVE-2023-49299","markdown":"https://insights.sbomify.com/CVE-2023-49299/index.md","name":"CVE-2023-49299","record":{"aliases":["GHSA-v7hg-77v9-2445"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache DolphinScheduler","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary JavaScript as root on the server, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"dolphinscheduler","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.This issue affects Apache DolphinScheduler: until 3.1.9.\n\nUsers are recommended to upgrade to version 3.1.9, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache DolphinScheduler: Arbitrary js execute as root for authenticated users","id":"CVE-2023-49299","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2023-49312"},"packages":[{"ecosystem":"Maven","fixed":["3.1.9"],"introduced":["0"],"last_affected":[],"package":"org.apache.dolphinscheduler:dolphinscheduler-master","purl":null,"source":"GHSA-v7hg-77v9-2445"},{"ecosystem":"Maven","fixed":["3.1.9"],"introduced":["0"],"last_affected":[],"package":"org.apache.dolphinscheduler:dolphinscheduler-master","purl":"pkg:maven/org.apache.dolphinscheduler/dolphinscheduler-master","source":"GHSA-v7hg-77v9-2445"}],"prev":{"headline":"Other in n/a","id":"CVE-2023-49298"},"products":["Apache DolphinScheduler"],"published":"2023-12-30","related":[{"cvss_score":9.8,"headline":"Apache DolphinScheduler Incorrect Default Permissions Vulnerability","id":"CVE-2024-43166","kev_date_added":null,"published":"2025-09-03"},{"cvss_score":9.8,"headline":"Apache DolphinScheduler: Remote Code Execution Vulnerability","id":"CVE-2024-43202","kev_date_added":null,"published":"2024-08-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in Apache Dolphinscheduler","id":"CVE-2023-49109","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":9.8,"headline":"Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin","id":"CVE-2022-45875","kev_date_added":null,"published":"2023-01-04"},{"cvss_score":9.8,"headline":"Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability","id":"CVE-2022-45462","kev_date_added":null,"published":"2022-11-23"},{"cvss_score":9.8,"headline":"Remote code execution in DolphinScheduler","id":"CVE-2020-11974","kev_date_added":null,"published":"2020-12-18"},{"cvss_score":8.8,"headline":"Apache DolphinScheduler: General user can mint admin access tokens via /access-tokens","id":"CVE-2026-49050","kev_date_added":null,"published":"2026-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can execute arbitrary JavaScript as root on the server, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2023-49299/"}