{"answers":{"affected":"2 open source packages ship an affected version, including phpseclib/phpseclib. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49316 in the wild and no public exploit code.","fix":"Upgrade phpseclib/phpseclib to 3.0.34 or later.","what":"CVE-2023-49316 is a high-severity denial of service vulnerability in n/a, published on 27 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49316 and fix it if it is affected.\n\nWhat it is: CVE-2023-49316 is a high-severity denial of service vulnerability in n/a, published on 27 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-49316 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.34\n- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.34\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49316/ (Markdown: https://insights.sbomify.com/CVE-2023-49316/index.md)","id":"CVE-2023-49316","markdown":"https://insights.sbomify.com/CVE-2023-49316/index.md","name":"CVE-2023-49316","record":{"aliases":["DEBIAN-CVE-2023-49316","GHSA-2f25-pfq3-c7h8","UBUNTU-CVE-2023-49316"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP cryptography library","requires_auth":"none","summary":"Attackers can cause denial of service in phpseclib by supplying excessively large degrees to the BinaryField class.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpseclib","vendor":"phpseclib"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-834","name":"Excessive Iteration"}],"description":"In Math/BinaryField.php in phpseclib 3 before 3.0.34, excessively large degrees can lead to a denial of service.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Phpseclib needs guardrails on large binaryfield integers","id":"CVE-2023-49316","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2023-49321"},"packages":[{"ecosystem":"Packagist","fixed":["3.0.34"],"introduced":["3.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":null,"source":"GHSA-2f25-pfq3-c7h8"},{"ecosystem":"Packagist","fixed":["3.0.34"],"introduced":["3.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":"pkg:composer/phpseclib/phpseclib","source":"GHSA-2f25-pfq3-c7h8"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2023-49314"},"products":["n/a"],"published":"2023-11-27","related":[{"cvss_score":8.2,"headline":"phpseclib's AES-CBC unpadding susceptible to padding oracle timing attack","id":"CVE-2026-32935","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":7.5,"headline":"Name confusion in x509 Subject Alternative Name fields","id":"CVE-2023-52892","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":7.5,"headline":"phpseclib Infinite Loop vulnerability","id":"CVE-2023-27560","kev_date_added":null,"published":"2023-03-03"},{"cvss_score":5.8,"headline":"phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority Information Access","id":"CVE-2026-55599","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":3.7,"headline":"phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals()","id":"CVE-2026-40194","kev_date_added":null,"published":"2026-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can cause denial of service in phpseclib by supplying excessively large degrees to the BinaryField class.","url":"https://insights.sbomify.com/CVE-2023-49316/"}