CVE-2023-49329 Command injection in n/a
An authenticated admin can inject OS commands in Anomali Match, leading to code execution and privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-49329?
CVE-2023-49329 is a high-severity command injection vulnerability in n/a, published on 19 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Anomali Match before 4.6.2 allows OS Command Injection. An authenticated admin user can inject and execute operating system commands. This arises from improper handling of untrusted input, enabling an attacker to elevate privileges, execute system commands, and potentially compromise the underlying operating system. The fixed versions are 4.4.5, 4.5.4, and 4.6.2. The earliest affected version is 4.3.
Weakness: CWE-78
Which versions are affected by CVE-2023-49329?
It affects 1 product.
Products include Anomali Match.
How do I fix CVE-2023-49329?
No fix has been published for CVE-2023-49329 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2023-49329 being exploited?
There is no known exploitation of CVE-2023-49329 in the wild and no public exploit code.
Sources
Also known as GHSA-627q-75vf-554c.