# CVE-2023-49329: Command injection in n/a

> An authenticated admin can inject OS commands in Anomali Match, leading to code execution and privilege escalation.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-627q-75vf-554c

## What is CVE-2023-49329?

CVE-2023-49329 is a high-severity command injection vulnerability in n/a, published on 19 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Anomali Match before 4.6.2 allows OS Command Injection. An authenticated admin user can inject and execute operating system commands. This arises from improper handling of untrusted input, enabling an attacker to elevate privileges, execute system commands, and potentially compromise the underlying operating system. The fixed versions are 4.4.5, 4.5.4, and 4.6.2. The earliest affected version is 4.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-49329?

It affects 1 product.


Products: Anomali Match.

## How do I fix CVE-2023-49329?

No fix has been published for CVE-2023-49329 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-49329 being exploited?

There is no known exploitation of CVE-2023-49329 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49329 and fix it if it is affected.

What it is: CVE-2023-49329 is a high-severity command injection vulnerability in n/a, published on 19 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49329 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49329/ (Markdown: https://insights.sbomify.com/CVE-2023-49329/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49329
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49329
- OSV: https://osv.dev/vulnerability/CVE-2023-49329

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49329/
Summaries are generated and may contain mistakes; the official description above is the record.
