CVE-2023-49337 Concrete CMS Stored XSS

Low 2.4 Published Updated

An attacker can inject malicious scripts into the Concrete CMS admin dashboard, potentially leading to session hijacking or unauthorized actions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-49337?

CVE-2023-49337 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 25 Dec 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS before 9.2.3 allows Stored XSS on the Admin Dashboard via /dashboard/system/basics/name. (8.5 and earlier are unaffected.)

Weakness: CWE-79

Which versions are affected by CVE-2023-49337?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistFrom 9.0.09.2.3
concrete5/concrete5 PackagistFrom 9.0.09.2.3

Products include Concretecms Concrete Cms.

How do I fix CVE-2023-49337?

Upgrade concrete5/concrete5 to 9.2.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-49337 being exploited?

There is no known exploitation of CVE-2023-49337 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-9xxv-q6pp-96wq.

Is CVE-2023-49337 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free