# CVE-2023-49438: Open redirect vulnerability in Flask-Security-Too

> Attackers can redirect users to malicious sites via crafted URLs in Flask-Security-Too, potentially facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Dec 2023
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-672h-6x89-76m5, PYSEC-2023-248, openSUSE-SU-2024:13563-1

## What is CVE-2023-49438?

CVE-2023-49438 is a medium-severity vulnerability in n/a, published on 26 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2023-49438?

3 open source packages ship an affected version, including flask-security-too and Flask-Security-Too. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-security-too` | PyPI | All versions | 5.3.3 |
| `flask-security-too` | PyPI | All versions | 5.3.3 |
| `Flask-Security-Too` | PyPI | All versions | 5.3.3 |

Products: Flask-Security-Too Project Flask-Security-Too.

## How do I fix CVE-2023-49438?

Upgrade flask-security-too to 5.3.3 or later.

## Is CVE-2023-49438 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49438 exists.

Public exploit code:

- CVE-2023-49438 - Open Redirect Vulnerability in Flask-Security-Too (github_poc): https://github.com/brandon-t-elliott/CVE-2023-49438
- Python Flask-Security-Too <=5.3.2 - Open Redirect (nuclei): http/cves/2023/CVE-2023-49438.yaml

## Other vulnerabilities in n/a

- [CVE-2021-21241](https://insights.sbomify.com/CVE-2021-21241/): CSRF can expose users authentication token in Flask-Security-Too (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49438 and fix it if it is affected.

What it is: CVE-2023-49438 is a medium-severity vulnerability in n/a, published on 26 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49438 exists.

Affected packages and fixed versions:
- flask-security-too (PyPI): affected all versions; fixed in 5.3.3
- flask-security-too (PyPI): affected all versions; fixed in 5.3.3
- Flask-Security-Too (PyPI): affected all versions; fixed in 5.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49438/ (Markdown: https://insights.sbomify.com/CVE-2023-49438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49438
- OSV: https://osv.dev/vulnerability/CVE-2023-49438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49438/
Summaries are generated and may contain mistakes; the official description above is the record.
