# CVE-2023-49508: YetiForceCRM Directory Traversal vulnerability

> Remote authenticated attackers can exploit a directory traversal flaw in YetiForce CRM to access sensitive information via the license parameter.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2024
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-394m-vxwj-363j

## What is CVE-2023-49508?

CVE-2023-49508 is a medium-severity path traversal vulnerability in n/a, published on 16 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directory Traversal vulnerability in YetiForceCompany YetiForceCRM versions 6.4.0 and before allows a remote authenticated attacker to obtain sensitive information via the license parameter in the LibraryLicense.php component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-49508?

2 open source packages ship an affected version, including yetiforce/yetiforce-crm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yetiforce/yetiforce-crm` | Packagist | All versions | 6.5.0 |
| `yetiforce/yetiforce-crm` | Packagist | All versions | 6.5.0 |

Products: Yetiforce Yetiforce Customer Relationship Management.

## How do I fix CVE-2023-49508?

Upgrade yetiforce/yetiforce-crm to 6.5.0 or later.

## Is CVE-2023-49508 being exploited?

There is no known exploitation of CVE-2023-49508 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-1411](https://insights.sbomify.com/CVE-2022-1411/): Unrestructed file upload in yetiforcecompany/yetiforcecrm (critical 9.1)
- [CVE-2022-2890](https://insights.sbomify.com/CVE-2022-2890/): Cross-site Scripting (XSS) - Stored in yetiforcecompany/yetiforcecrm (critical 9.0)
- [CVE-2022-2829](https://insights.sbomify.com/CVE-2022-2829/): Cross-site Scripting (XSS) - Stored in yetiforcecompany/yetiforcecrm (high 8.8)
- [CVE-2022-0269](https://insights.sbomify.com/CVE-2022-0269/): Cross-Site Request Forgery (CSRF) in yetiforcecompany/yetiforcecrm (high 8.0)
- [CVE-2021-4117](https://insights.sbomify.com/CVE-2021-4117/): Business Logic Errors in yetiforcecompany/yetiforcecrm (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49508 and fix it if it is affected.

What it is: CVE-2023-49508 is a medium-severity path traversal vulnerability in n/a, published on 16 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49508 in the wild and no public exploit code.

Affected packages and fixed versions:
- yetiforce/yetiforce-crm (Packagist): affected all versions; fixed in 6.5.0
- yetiforce/yetiforce-crm (Packagist): affected all versions; fixed in 6.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49508/ (Markdown: https://insights.sbomify.com/CVE-2023-49508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49508
- OSV: https://osv.dev/vulnerability/CVE-2023-49508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49508/
Summaries are generated and may contain mistakes; the official description above is the record.
