{"answers":{"affected":"6 open source packages ship an affected version, including github.com/vektah/gqlparser and github.com/vektah/gqlparser/v2.","exploited":"There is no known exploitation of CVE-2023-49559 in the wild and no public exploit code.","fix":"Upgrade github.com/vektah/gqlparser to 2.5.14 or later.","what":"CVE-2023-49559 is a low-severity denial of service vulnerability in n/a, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49559 and fix it if it is affected.\n\nWhat it is: CVE-2023-49559 is a low-severity denial of service vulnerability in n/a, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-49559 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/vektah/gqlparser (Go): affected all versions; no fix listed\n- github.com/vektah/gqlparser (Go): affected all versions; fixed in 2.5.14\n- github.com/vektah/gqlparser (Go): affected all versions; fixed in 2.5.14\n- github.com/vektah/gqlparser/v2 (Go): affected all versions; fixed in 2.5.14\n- github.com/vektah/gqlparser/v2 (Go): affected all versions; fixed in 2.5.14\n- github.com/vektah/gqlparser/v2 (Go): affected all versions; fixed in 2.5.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49559/ (Markdown: https://insights.sbomify.com/CVE-2023-49559/index.md)","id":"CVE-2023-49559","markdown":"https://insights.sbomify.com/CVE-2023-49559/index.md","name":"CVE-2023-49559","record":{"aliases":["GHSA-2hmf-46v7-v6fx","GO-2024-2920"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go GraphQL parser","requires_auth":"none","summary":"A remote attacker can cause a denial of service in the gqlparser library by sending a crafted script to the parserDirectives function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"An issue in vektah gqlparser open-source-library v.2.5.10 allows a remote attacker to cause a denial of service via a crafted script to the parserDirectives function.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"gqlparser denial of service vulnerability via the parserDirectives function","id":"CVE-2023-49559","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":6,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-49563"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/vektah/gqlparser","purl":"pkg:golang/github.com/vektah/gqlparser","source":"GO-2024-2920"},{"ecosystem":"Go","fixed":["2.5.14"],"introduced":["0"],"last_affected":[],"package":"github.com/vektah/gqlparser","purl":null,"source":"GHSA-2hmf-46v7-v6fx"},{"ecosystem":"Go","fixed":["2.5.14"],"introduced":["0"],"last_affected":[],"package":"github.com/vektah/gqlparser","purl":"pkg:golang/github.com/vektah/gqlparser","source":"GHSA-2hmf-46v7-v6fx"},{"ecosystem":"Go","fixed":["2.5.14"],"introduced":["0"],"last_affected":[],"package":"github.com/vektah/gqlparser/v2","purl":null,"source":"GHSA-2hmf-46v7-v6fx"},{"ecosystem":"Go","fixed":["2.5.14"],"introduced":["0"],"last_affected":[],"package":"github.com/vektah/gqlparser/v2","purl":"pkg:golang/github.com/vektah/gqlparser/v2","source":"GHSA-2hmf-46v7-v6fx"},{"ecosystem":"Go","fixed":["2.5.14"],"introduced":["0"],"last_affected":[],"package":"github.com/vektah/gqlparser/v2","purl":"pkg:golang/github.com/vektah/gqlparser/v2","source":"GO-2024-2920"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2023-49558"},"products":["n/a"],"published":"2024-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-03","vendors":["n/a"]},"summary":"A remote attacker can cause a denial of service in the gqlparser library by sending a crafted script to the parserDirectives function.","url":"https://insights.sbomify.com/CVE-2023-49559/"}