# CVE-2023-49559: gqlparser denial of service vulnerability via the parserDirectives function

> A remote attacker can cause a denial of service in the gqlparser library by sending a crafted script to the parserDirectives function.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2024
- **Updated:** 3 Dec 2024
- **Also known as:** GHSA-2hmf-46v7-v6fx, GO-2024-2920

## What is CVE-2023-49559?

CVE-2023-49559 is a low-severity denial of service vulnerability in n/a, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in vektah gqlparser open-source-library v.2.5.10 allows a remote attacker to cause a denial of service via a crafted script to the parserDirectives function.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-49559?

6 open source packages ship an affected version, including github.com/vektah/gqlparser and github.com/vektah/gqlparser/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/vektah/gqlparser` | Go | All versions | None |
| `github.com/vektah/gqlparser` | Go | All versions | 2.5.14 |
| `github.com/vektah/gqlparser` | Go | All versions | 2.5.14 |
| `github.com/vektah/gqlparser/v2` | Go | All versions | 2.5.14 |
| `github.com/vektah/gqlparser/v2` | Go | All versions | 2.5.14 |
| `github.com/vektah/gqlparser/v2` | Go | All versions | 2.5.14 |

## How do I fix CVE-2023-49559?

Upgrade github.com/vektah/gqlparser to 2.5.14 or later.

## Is CVE-2023-49559 being exploited?

There is no known exploitation of CVE-2023-49559 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49559 and fix it if it is affected.

What it is: CVE-2023-49559 is a low-severity denial of service vulnerability in n/a, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49559 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/vektah/gqlparser (Go): affected all versions; no fix listed
- github.com/vektah/gqlparser (Go): affected all versions; fixed in 2.5.14
- github.com/vektah/gqlparser (Go): affected all versions; fixed in 2.5.14
- github.com/vektah/gqlparser/v2 (Go): affected all versions; fixed in 2.5.14
- github.com/vektah/gqlparser/v2 (Go): affected all versions; fixed in 2.5.14
- github.com/vektah/gqlparser/v2 (Go): affected all versions; fixed in 2.5.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49559/ (Markdown: https://insights.sbomify.com/CVE-2023-49559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49559
- OSV: https://osv.dev/vulnerability/CVE-2023-49559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49559/
Summaries are generated and may contain mistakes; the official description above is the record.
