CVE-2023-49582 Apache Portable Runtime (APR): Unexpected lax shared memory permissions
Local attackers can read sensitive data from shared memory segments due to lax permissions in the Apache Portable Runtime library on Unix systems.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-49582?
CVE-2023-49582 is a medium-severity vulnerability in Apache Portable Runtime (APR), published on 26 Aug 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data.
This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h)
Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.
Weakness: CWE-732
Which versions are affected by CVE-2023-49582?
1 open source package ship an affected version, including apr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apr Bitnami | From 0.9.0 | 1.7.5 |
Linux distribution packages (8)
apr SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.6.3-150000.3.6.1 |
apr SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.6.3-150000.3.6.1 |
libapr1 SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.5.1-4.8.1 |
libapr1 SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.5.1-4.8.1 |
libapr1 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 1.5.1-4.8.1 |
apr openSUSE:Leap 15.5 | All versions | 1.6.3-150000.3.6.1 |
apr openSUSE:Leap 15.6 | All versions | 1.6.3-150000.3.6.1 |
apr openSUSE:Tumbleweed | All versions | 1.7.5-1.1 |
Products include Apache Portable Runtime.
How do I fix CVE-2023-49582?
Upgrade apr to 1.7.5 or later.
Is CVE-2023-49582 being exploited?
There is no known exploitation of CVE-2023-49582 in the wild and no public exploit code.
Other vulnerabilities in Apache Portable Runtime (APR)
- CVE-2022-24963 Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions
- CVE-2022-28331 Apache Portable Runtime (APR): Windows out-of-bounds write in apr_socket_sendv function
- CVE-2021-35940 Regression of CVE-2017-12613
- CVE-2017-12613 Information disclosure in Apache Portable Runtime
- CVE-2012-0840 Denial of service in n/a
Sources
Also known as ALPINE-CVE-2023-49582, AZL-48216, AZL-48273, BELL-CVE-2023-49582, BIT-apr-2023-49582, DEBIAN-CVE-2023-49582 and 10 more.