# CVE-2023-49582: Apache Portable Runtime (APR): Unexpected lax shared memory permissions

> Local attackers can read sensitive data from shared memory segments due to lax permissions in the Apache Portable Runtime library on Unix systems.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2024
- **Updated:** 13 Mar 2025
- **Also known as:** ALPINE-CVE-2023-49582, AZL-48216, AZL-48273, BELL-CVE-2023-49582, BIT-apr-2023-49582, DEBIAN-CVE-2023-49582, GHSA-j26h-qjc9-68hh, MGASA-2024-0292, OESA-2024-2229, ROOT-OS-DEBIAN-11-CVE-2023-49582, SUSE-SU-2024:3428-1, SUSE-SU-2024:3429-1, UBUNTU-CVE-2023-49582, USN-7038-1, USN-7038-2, openSUSE-SU-2024:14347-1

## What is CVE-2023-49582?

CVE-2023-49582 is a medium-severity vulnerability in Apache Portable Runtime (APR), published on 26 Aug 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. 

This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h)

Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2023-49582?

1 open source package ship an affected version, including apr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apr` | Bitnami | From 0.9.0 | 1.7.5 |
| `apr` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.6.3-150000.3.6.1 |
| `apr` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.6.3-150000.3.6.1 |
| `libapr1` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.5.1-4.8.1 |
| `libapr1` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.5.1-4.8.1 |
| `libapr1` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 1.5.1-4.8.1 |
| `apr` | openSUSE:Leap 15.5 | All versions | 1.6.3-150000.3.6.1 |
| `apr` | openSUSE:Leap 15.6 | All versions | 1.6.3-150000.3.6.1 |
| `apr` | openSUSE:Tumbleweed | All versions | 1.7.5-1.1 |

Products: Apache Portable Runtime.

## How do I fix CVE-2023-49582?

Upgrade apr to 1.7.5 or later.

## Is CVE-2023-49582 being exploited?

There is no known exploitation of CVE-2023-49582 in the wild and no public exploit code.

## Other vulnerabilities in Apache Portable Runtime (APR)

- [CVE-2022-24963](https://insights.sbomify.com/CVE-2022-24963/): Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions (critical 9.8)
- [CVE-2022-28331](https://insights.sbomify.com/CVE-2022-28331/): Apache Portable Runtime (APR): Windows out-of-bounds write in apr_socket_sendv function (critical 9.8)
- [CVE-2021-35940](https://insights.sbomify.com/CVE-2021-35940/): Regression of CVE-2017-12613 (high 7.1)
- [CVE-2017-12613](https://insights.sbomify.com/CVE-2017-12613/): Information disclosure in Apache Portable Runtime (high 7.1)
- [CVE-2012-0840](https://insights.sbomify.com/CVE-2012-0840/): Denial of service in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49582 and fix it if it is affected.

What it is: CVE-2023-49582 is a medium-severity vulnerability in Apache Portable Runtime (APR), published on 26 Aug 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49582 in the wild and no public exploit code.

Affected packages and fixed versions:
- apr (Bitnami): affected from 0.9.0; fixed in 1.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49582/ (Markdown: https://insights.sbomify.com/CVE-2023-49582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49582
- OSV: https://osv.dev/vulnerability/CVE-2023-49582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49582/
Summaries are generated and may contain mistakes; the official description above is the record.
