# CVE-2023-49583: Escalation of Privileges in SAP BTP Security Services Integration Library ([Node.js] @sap/xssec)

> An unauthenticated attacker can escalate privileges to obtain arbitrary permissions in applications using the vulnerable SAP BTP security library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2023
- **Updated:** 25 Feb 2026
- **Also known as:** GHSA-p2vx-qj66-88q3

## What is CVE-2023-49583?

CVE-2023-49583 is a critical vulnerability in SAP_SE @sap/xssec, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SAP BTP Security Services Integration Library ([Node.js] @sap/xssec - versions < 3.6.0, allow under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2023-49583?

2 open source packages ship an affected version, including @sap/xssec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sap/xssec` | npm | All versions | 3.6.0 |
| `@sap/xssec` | npm | All versions | 3.6.0 |

Products: Sap \@Sap\/Xssec.

## How do I fix CVE-2023-49583?

Upgrade @sap/xssec to 3.6.0 or later.

## Is CVE-2023-49583 being exploited?

There is no known exploitation of CVE-2023-49583 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49583 and fix it if it is affected.

What it is: CVE-2023-49583 is a critical vulnerability in SAP_SE @sap/xssec, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49583 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sap/xssec (npm): affected all versions; fixed in 3.6.0
- @sap/xssec (npm): affected all versions; fixed in 3.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49583/ (Markdown: https://insights.sbomify.com/CVE-2023-49583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49583
- OSV: https://osv.dev/vulnerability/CVE-2023-49583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49583/
Summaries are generated and may contain mistakes; the official description above is the record.
