# CVE-2023-49620: Apache DolphinScheduler: Authenticated users could delete UDFs in resource center they were not authorized for

> Authenticated users can delete unauthorized UDFs in the resource center due to missing authorization checks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Nov 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-r44q-98gx-pmh2

## What is CVE-2023-49620?

CVE-2023-49620 is a medium-severity missing authorization vulnerability in Apache DolphinScheduler, published on 30 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Before DolphinScheduler version 3.1.0, the login user could delete UDF function in the resource center unauthorized (which almost used in sql task), with unauthorized access vulnerability (IDOR), but after version 3.1.0 we fixed this issue. We mark this cve as moderate level because it still requires user login to operate, please upgrade to version 3.1.0 to avoid this vulnerability

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-49620?

8 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler-api, org.apache.dolphinscheduler:dolphinscheduler-common and org.apache.dolphinscheduler:dolphinscheduler-dao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dolphinscheduler:dolphinscheduler-api` | Maven | All versions | 3.1.0 |
| `org.apache.dolphinscheduler:dolphinscheduler-api` | Maven | All versions | 3.1.0 |
| `org.apache.dolphinscheduler:dolphinscheduler-common` | Maven | All versions | 3.1.0 |
| `org.apache.dolphinscheduler:dolphinscheduler-common` | Maven | All versions | 3.1.0 |
| `org.apache.dolphinscheduler:dolphinscheduler-dao` | Maven | All versions | 3.1.0 |
| `org.apache.dolphinscheduler:dolphinscheduler-dao` | Maven | All versions | 3.1.0 |
| `org.apache.dolphinscheduler:dolphinscheduler-service` | Maven | All versions | 3.1.0 |
| `org.apache.dolphinscheduler:dolphinscheduler-service` | Maven | All versions | 3.1.0 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2023-49620?

Upgrade org.apache.dolphinscheduler:dolphinscheduler-api to 3.1.0 or later.

## Is CVE-2023-49620 being exploited?

There is no known exploitation of CVE-2023-49620 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45875](https://insights.sbomify.com/CVE-2022-45875/): Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49620 and fix it if it is affected.

What it is: CVE-2023-49620 is a medium-severity missing authorization vulnerability in Apache DolphinScheduler, published on 30 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49620 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dolphinscheduler:dolphinscheduler-api (Maven): affected all versions; fixed in 3.1.0
- org.apache.dolphinscheduler:dolphinscheduler-api (Maven): affected all versions; fixed in 3.1.0
- org.apache.dolphinscheduler:dolphinscheduler-common (Maven): affected all versions; fixed in 3.1.0
- org.apache.dolphinscheduler:dolphinscheduler-common (Maven): affected all versions; fixed in 3.1.0
- org.apache.dolphinscheduler:dolphinscheduler-dao (Maven): affected all versions; fixed in 3.1.0
- org.apache.dolphinscheduler:dolphinscheduler-dao (Maven): affected all versions; fixed in 3.1.0
- org.apache.dolphinscheduler:dolphinscheduler-service (Maven): affected all versions; fixed in 3.1.0
- org.apache.dolphinscheduler:dolphinscheduler-service (Maven): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49620/ (Markdown: https://insights.sbomify.com/CVE-2023-49620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49620
- OSV: https://osv.dev/vulnerability/CVE-2023-49620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49620/
Summaries are generated and may contain mistakes; the official description above is the record.
