# CVE-2023-49652: Jenkins Google Compute Engine Plugin has incorrect permission checks

> Attackers with global configure permissions can enumerate system credentials and access Google Cloud projects due to missing authorization checks in the Jenkins GCE plugin.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-pgpj-83g3-mfr2

## What is CVE-2023-49652?

CVE-2023-49652 is a low-severity missing authorization vulnerability in Jenkins Google Compute Engine Plugin, published on 29 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Incorrect permission checks in Jenkins Google Compute Engine Plugin 4.550.vb_327fca_3db_11 and earlier allow attackers with global Item/Configure permission (while lacking Item/Configure permission on any particular job) to enumerate system-scoped credentials IDs of credentials stored in Jenkins and to connect to Google Cloud Platform using attacker-specified credentials IDs obtained through another method, to obtain information about existing projects. This fix has been backported to 4.3.17.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-49652?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:google-compute-engine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:google-compute-engine` | Maven | All versions | 4.3.17.1 |
| `org.jenkins-ci.plugins:google-compute-engine` | Maven | All versions | 4.3.17.1 |
| `org.jenkins-ci.plugins:google-compute-engine` | Maven | From 4.5 | 4.551.v5a |
| `org.jenkins-ci.plugins:google-compute-engine` | Maven | From 4.5 | 4.551.v5a |

Products: Jenkins Google Compute Engine.

## How do I fix CVE-2023-49652?

Upgrade org.jenkins-ci.plugins:google-compute-engine to a fixed version for your release line: 4.3.17.1 or 4.551.v5a.

## Is CVE-2023-49652 being exploited?

There is no known exploitation of CVE-2023-49652 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Google Compute Engine Plugin

- [CVE-2023-49673](https://insights.sbomify.com/CVE-2023-49673/): Jenkins NeuVector Vulnerability Scanner Plugin Cross-Site Request Forgery vulnerability (high 8.8)
- [CVE-2019-16548](https://insights.sbomify.com/CVE-2019-16548/): Jenkins Google Compute Engine Plugin Cross-Site Request Forgery vulnerability (high 8.8)
- [CVE-2019-16546](https://insights.sbomify.com/CVE-2019-16546/): Jenkins Google Compute Engine Plugin does not verify SSH host keys when connecting agents created by the plugin (medium 5.9)
- [CVE-2022-29052](https://insights.sbomify.com/CVE-2022-29052/): Private key stored in plain text by Jenkins Google Compute Engine Plugin (medium 4.3)
- [CVE-2019-16547](https://insights.sbomify.com/CVE-2019-16547/): Jenkins Google Compute Engine Plugin Missing Authorization vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49652 and fix it if it is affected.

What it is: CVE-2023-49652 is a low-severity missing authorization vulnerability in Jenkins Google Compute Engine Plugin, published on 29 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49652 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:google-compute-engine (Maven): affected all versions; fixed in 4.3.17.1
- org.jenkins-ci.plugins:google-compute-engine (Maven): affected all versions; fixed in 4.3.17.1
- org.jenkins-ci.plugins:google-compute-engine (Maven): affected from 4.5; fixed in 4.551.v5a
- org.jenkins-ci.plugins:google-compute-engine (Maven): affected from 4.5; fixed in 4.551.v5a

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49652/ (Markdown: https://insights.sbomify.com/CVE-2023-49652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49652
- OSV: https://osv.dev/vulnerability/CVE-2023-49652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49652/
Summaries are generated and may contain mistakes; the official description above is the record.
