# CVE-2023-49657: Apache Superset: Stored XSS in Dashboard Title and Chart Title

> An authenticated attacker can inject malicious scripts into dashboard or chart titles, leading to stored XSS attacks against other users.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** BIT-superset-2023-49657, GHSA-rwhh-6x83-84v6, PYSEC-2026-280

## What is CVE-2023-49657?

CVE-2023-49657 is a critical cross-site scripting vulnerability in Apache Superset, published on 23 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A stored cross-site scripting (XSS) vulnerability exists in Apache Superset before 3.0.3. An authenticated attacker with create/update permissions on charts or dashboards could store a script or add a specific HTML snippet that would act as a stored XSS.

For 2.X versions, users should change their config to include:

TALISMAN_CONFIG = {
    "content_security_policy": {
        "base-uri": ["'self'"],
        "default-src": ["'self'"],
        "img-src": ["'self'", "blob:", "data:"],
        "worker-src": ["'self'", "blob:"],
        "connect-src": [
            "'self'",
            " https://api.mapbox.com" https://api.mapbox.com" ;,
            " https://events.mapbox.com" https://events.mapbox.com" ;,
        ],
        "object-src": "'none'",
        "style-src": [
            "'self'",
            "'unsafe-inline'",
        ],
        "script-src": ["'self'", "'strict-dynamic'"],
    },
    "content_security_policy_nonce_in": ["script-src"],
    "force_https": False,
    "session_cookie_secure": False,
}

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-49657?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 3.0.3 |
| `apache-superset` | PyPI | All versions | 3.0.3 |
| `apache-superset` | PyPI | All versions | 3.0.3 |
| `superset` | Bitnami | All versions | 3.0.3 |

Products: Apache Superset.

## How do I fix CVE-2023-49657?

Upgrade apache-superset to 3.0.3 or later.

## Is CVE-2023-49657 being exploited?

There is no known exploitation of CVE-2023-49657 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)
- [CVE-2021-41971](https://insights.sbomify.com/CVE-2021-41971/): Possible SQL Injection when template processing is enabled (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49657 and fix it if it is affected.

What it is: CVE-2023-49657 is a critical cross-site scripting vulnerability in Apache Superset, published on 23 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49657 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 3.0.3
- apache-superset (PyPI): affected all versions; fixed in 3.0.3
- apache-superset (PyPI): affected all versions; fixed in 3.0.3
- superset (Bitnami): affected all versions; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49657/ (Markdown: https://insights.sbomify.com/CVE-2023-49657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49657
- OSV: https://osv.dev/vulnerability/CVE-2023-49657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49657/
Summaries are generated and may contain mistakes; the official description above is the record.
