CVE-2023-49734 Apache Superset: Privilege Escalation Vulnerability

High 7.7 Published Updated

Authenticated Gamma users can gain unauthorized write permissions to charts by creating dashboards, allowing privilege escalation and data modification.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-49734?

CVE-2023-49734 is a high-severity vulnerability in Apache Superset, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2.

Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2023-49734?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions2.1.3, 3.0.2
apache-superset PyPIAll versions2.1.3
apache-superset PyPIAll versions2.1.3
apache-superset PyPIFrom 3.0.03.0.2
apache-superset PyPIFrom 3.0.03.0.2
superset BitnamiAll versions2.1.2, 3.0.2

Products include Apache Superset.

How do I fix CVE-2023-49734?

Upgrade apache-superset to a fixed version for your release line: 2.1.3 or 3.0.2.

Is CVE-2023-49734 being exploited?

There is no known exploitation of CVE-2023-49734 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2023-49734, GHSA-g49j-j489-3xpf, PYSEC-2026-1180.

Is CVE-2023-49734 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free