CVE-2023-49736 Apache Superset: SQL Injection on where_in JINJA macro
Attackers can execute arbitrary SQL commands via the where_in JINJA macro, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-49736?
CVE-2023-49736 is a medium-severity SQL injection vulnerability in Apache Superset, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2.
Users are recommended to upgrade to version 3.0.2, which fixes the issue.
Weakness: CWE-89
Which versions are affected by CVE-2023-49736?
6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | 2.1.3, 3.0.2 |
apache-superset PyPI | All versions | 2.1.3 |
apache-superset PyPI | All versions | 2.1.3 |
apache-superset PyPI | From 3.0.0 | 3.0.2 |
apache-superset PyPI | From 3.0.0 | 3.0.2 |
superset Bitnami | All versions | 2.1.2, 3.0.2 |
Products include Apache Superset.
How do I fix CVE-2023-49736?
Upgrade apache-superset to a fixed version for your release line: 2.1.3 or 3.0.2.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2023-49736 being exploited?
There is no known exploitation of CVE-2023-49736 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2023-49736, GHSA-jfxj-xf67-x723, PYSEC-2026-1184.