{"answers":{"affected":"6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49736 in the wild and no public exploit code.","fix":"Upgrade apache-superset to a fixed version for your release line: 2.1.3 or 3.0.2.","what":"CVE-2023-49736 is a medium-severity SQL injection vulnerability in Apache Superset, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49736 and fix it if it is affected.\n\nWhat it is: CVE-2023-49736 is a medium-severity SQL injection vulnerability in Apache Superset, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-49736 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions; fixed in 2.1.3, 3.0.2\n- apache-superset (PyPI): affected all versions; fixed in 2.1.3\n- apache-superset (PyPI): affected all versions; fixed in 2.1.3\n- apache-superset (PyPI): affected from 3.0.0; fixed in 3.0.2\n- apache-superset (PyPI): affected from 3.0.0; fixed in 3.0.2\n- superset (Bitnami): affected all versions; fixed in 2.1.2, 3.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49736/ (Markdown: https://insights.sbomify.com/CVE-2023-49736/index.md)","id":"CVE-2023-49736","markdown":"https://insights.sbomify.com/CVE-2023-49736/index.md","name":"CVE-2023-49736","record":{"aliases":["BIT-superset-2023-49736","GHSA-jfxj-xf67-x723","PYSEC-2026-1184"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary SQL commands via the where_in JINJA macro, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2.\n\nUsers are recommended to upgrade to version 3.0.2, which fixes the issue.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: SQL Injection on where_in JINJA macro","id":"CVE-2023-49736","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"sql_injection","year":"2023"},"n_packages":6,"n_references":2,"next":{"headline":"Path traversal in AVideo","id":"CVE-2023-49738"},"packages":[{"ecosystem":"Bitnami","fixed":["2.1.2","3.0.2"],"introduced":["0","3.0.0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2023-49736"},{"ecosystem":"PyPI","fixed":["2.1.3","3.0.2"],"introduced":["0","3.0.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-1184"},{"ecosystem":"PyPI","fixed":["2.1.3"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-jfxj-xf67-x723"},{"ecosystem":"PyPI","fixed":["2.1.3"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-jfxj-xf67-x723"},{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-jfxj-xf67-x723"},{"ecosystem":"PyPI","fixed":["3.0.2"],"introduced":["3.0.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-jfxj-xf67-x723"}],"prev":{"headline":"Apache Tiles: Unvalidated input may lead to path traversal and XXE","id":"CVE-2023-49735"},"products":["Apache Superset"],"published":"2023-12-19","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary SQL commands via the where_in JINJA macro, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2023-49736/"}