# CVE-2023-49736: Apache Superset: SQL Injection on where_in JINJA macro

> Attackers can execute arbitrary SQL commands via the where_in JINJA macro, potentially reading or modifying database contents.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-superset-2023-49736, GHSA-jfxj-xf67-x723, PYSEC-2026-1184

## What is CVE-2023-49736?

CVE-2023-49736 is a medium-severity SQL injection vulnerability in Apache Superset, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2.

Users are recommended to upgrade to version 3.0.2, which fixes the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-49736?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 2.1.3, 3.0.2 |
| `apache-superset` | PyPI | All versions | 2.1.3 |
| `apache-superset` | PyPI | All versions | 2.1.3 |
| `apache-superset` | PyPI | From 3.0.0 | 3.0.2 |
| `apache-superset` | PyPI | From 3.0.0 | 3.0.2 |
| `superset` | Bitnami | All versions | 2.1.2, 3.0.2 |

Products: Apache Superset.

## How do I fix CVE-2023-49736?

Upgrade apache-superset to a fixed version for your release line: 2.1.3 or 3.0.2.

## Is CVE-2023-49736 being exploited?

There is no known exploitation of CVE-2023-49736 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49736 and fix it if it is affected.

What it is: CVE-2023-49736 is a medium-severity SQL injection vulnerability in Apache Superset, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49736 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 2.1.3, 3.0.2
- apache-superset (PyPI): affected all versions; fixed in 2.1.3
- apache-superset (PyPI): affected all versions; fixed in 2.1.3
- apache-superset (PyPI): affected from 3.0.0; fixed in 3.0.2
- apache-superset (PyPI): affected from 3.0.0; fixed in 3.0.2
- superset (Bitnami): affected all versions; fixed in 2.1.2, 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49736/ (Markdown: https://insights.sbomify.com/CVE-2023-49736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49736
- OSV: https://osv.dev/vulnerability/CVE-2023-49736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49736/
Summaries are generated and may contain mistakes; the official description above is the record.
