CVE-2023-49783 No permission checks for editing/deleting records with CSV import form
Users with create permissions can edit or delete records via CSV import despite lacking edit or delete permissions in Silverstripe Admin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-49783?
CVE-2023-49783 is a medium-severity missing authorization vulnerability in silverstripe-admin, published on 23 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Silverstripe Admin provides a basic management interface for the Silverstripe Framework. In versions on the 1.x branch prior to 1.13.19 and on the 2.x branch prior to 2.1.8, users who don't have edit or delete permissions for records exposed in a `ModelAdmin` can still edit or delete records using the CSV import form, provided they have create permissions. The likelihood of a user having create permissions but not having edit or delete permissions is low, but it is possible. Note that this doesn't affect any `ModelAdmin` which has had the import form disabled via the `showImportForm` public property. Versions 1.13.19 and 2.1.8 contain a patch for the issue. Those who have a custom implementation of `BulkLoader` should update their implementations to respect permissions when the return value of `getCheckPermissions()` is true. Those who use any `BulkLoader` in their own project logic, or maintain a module which uses it, should consider passing `true` to `setCheckPermissions()` if the data is provided by users.
Weakness: CWE-863
Which versions are affected by CVE-2023-49783?
4 open source packages ship an affected version, including silverstripe/admin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/admin Packagist | From 1.0.0 | 1.13.19 |
silverstripe/admin Packagist | From 1.0.0 | 1.13.19 |
silverstripe/admin Packagist | From 2.0.0 | 2.1.8 |
silverstripe/admin Packagist | From 2.0.0 | 2.1.8 |
Products include Silverstripe Admin.
How do I fix CVE-2023-49783?
Upgrade silverstripe/admin to a fixed version for your release line: 1.13.19 or 2.1.8.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-49783 being exploited?
There is no known exploitation of CVE-2023-49783 in the wild and no public exploit code.
Sources
Also known as GHSA-j3m6-gvm8-mhvw.