# CVE-2023-49793: Path traversal in `CodeChecker server` in the endpoint of `CodeChecker store`

> An authenticated attacker can exploit path traversal in CodeChecker server to read arbitrary files from the host system.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-h26w-r4m5-8rrf, PYSEC-2024-54

## What is CVE-2023-49793?

CVE-2023-49793 is a medium-severity path traversal vulnerability in Ericsson codechecker, published on 24 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CodeChecker is an analyzer tooling, defect database and viewer extension for the Clang Static Analyzer and Clang Tidy. Zip files uploaded to the server endpoint of `CodeChecker store` are not properly sanitized. An attacker, using a path traversal attack, can load and display files on the machine of `CodeChecker server`. The vulnerable endpoint is `/Default/v6.53/CodeCheckerService@massStoreRun`. The path traversal vulnerability allows reading data on the machine of the `CodeChecker server`, with the same permission level as the `CodeChecker server`.
The attack requires a user account on the `CodeChecker server`, with permission to store to a server, and view the stored report. This vulnerability has been patched in version 6.23.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-49793?

3 open source packages ship an affected version, including codechecker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codechecker` | PyPI | All versions | 6.23.0 |
| `codechecker` | PyPI | All versions | 6.23.0 |
| `codechecker` | PyPI | All versions | 6.23.0 |

Products: Ericsson Codechecker.

## How do I fix CVE-2023-49793?

Upgrade codechecker to 6.23.0 or later.

## Is CVE-2023-49793 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49793 exists.

## Other vulnerabilities in Ericsson codechecker

- [CVE-2024-10081](https://insights.sbomify.com/CVE-2024-10081/): codechecker vulnerable to authentication bypass when using specifically crafted URLs (critical 10.0)
- [CVE-2026-25660](https://insights.sbomify.com/CVE-2026-25660/): Authentication bypass for certain API calls (critical 9.3)
- [CVE-2024-10082](https://insights.sbomify.com/CVE-2024-10082/): codechecker authentication method confusion vulnerability allows logging in as the built-in root user from an external service (high 8.7)
- [CVE-2024-53829](https://insights.sbomify.com/CVE-2024-53829/): Cross-Site Request Forgery in CodeChecker API (high 8.2)
- [CVE-2025-1300](https://insights.sbomify.com/CVE-2025-1300/): Open redirect in CodeChecker web server (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49793 and fix it if it is affected.

What it is: CVE-2023-49793 is a medium-severity path traversal vulnerability in Ericsson codechecker, published on 24 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49793 exists.

Affected packages and fixed versions:
- codechecker (PyPI): affected all versions; fixed in 6.23.0
- codechecker (PyPI): affected all versions; fixed in 6.23.0
- codechecker (PyPI): affected all versions; fixed in 6.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49793/ (Markdown: https://insights.sbomify.com/CVE-2023-49793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49793
- OSV: https://osv.dev/vulnerability/CVE-2023-49793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49793/
Summaries are generated and may contain mistakes; the official description above is the record.
