# CVE-2023-49798: Duplicated execution of subcalls in OpenZeppelin Contracts

> A duplication bug in OpenZeppelin Contracts causes subcalls to execute twice, leading to unintended duplicate asset transfers.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-699g-q6qh-q4v8

## What is CVE-2023-49798?

CVE-2023-49798 is a medium-severity vulnerability in openzeppelin-contracts, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for smart contract development. A merge issue when porting the 5.0.1 patch to the 4.9 branch caused a line duplication. In the version of `Multicall.sol` released in `@openzeppelin/contracts@4.9.4` and `@openzeppelin/contracts-upgradeable@4.9.4`, all subcalls are executed twice. Concretely, this exposes a user to unintentionally duplicate operations like asset transfers. The duplicated delegatecall was removed in version 4.9.5. The 4.9.4 version is marked as deprecated. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2023-49798?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.9.4 | 4.9.5 |
| `@openzeppelin/contracts` | npm | From 4.9.4 | 4.9.5 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.9.4 | 4.9.5 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.9.4 | 4.9.5 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2023-49798?

Upgrade @openzeppelin/contracts to 4.9.5 or later.

## Is CVE-2023-49798 being exploited?

There is no known exploitation of CVE-2023-49798 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49798 and fix it if it is affected.

What it is: CVE-2023-49798 is a medium-severity vulnerability in openzeppelin-contracts, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49798 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.9.4; fixed in 4.9.5
- @openzeppelin/contracts (npm): affected from 4.9.4; fixed in 4.9.5
- @openzeppelin/contracts-upgradeable (npm): affected from 4.9.4; fixed in 4.9.5
- @openzeppelin/contracts-upgradeable (npm): affected from 4.9.4; fixed in 4.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49798/ (Markdown: https://insights.sbomify.com/CVE-2023-49798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49798
- OSV: https://osv.dev/vulnerability/CVE-2023-49798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49798/
Summaries are generated and may contain mistakes; the official description above is the record.
