{"answers":{"affected":"2 open source packages ship an affected version, including nuxt-api-party. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-49800 in the wild and no public exploit code.","fix":"Upgrade nuxt-api-party to 0.22.1 or later.","what":"CVE-2023-49800 is a high-severity denial of service vulnerability in johannschopplich nuxt-api-party, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49800 and fix it if it is affected.\n\nWhat it is: CVE-2023-49800 is a high-severity denial of service vulnerability in johannschopplich nuxt-api-party, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-49800 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nuxt-api-party (npm): affected all versions; fixed in 0.22.1\n- nuxt-api-party (npm): affected all versions; fixed in 0.22.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49800/ (Markdown: https://insights.sbomify.com/CVE-2023-49800/index.md)","id":"CVE-2023-49800","markdown":"https://insights.sbomify.com/CVE-2023-49800/index.md","name":"CVE-2023-49800","record":{"aliases":["GHSA-q6hx-3m4p-749h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Nuxt API proxy module","requires_auth":"none","summary":"Attackers can crash the server via stack overflow by abusing unfiltered retry options in the nuxt-api-party module.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nuxt_api_party","vendor":"johannschopplich"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"`nuxt-api-party` is an open source module to proxy API requests. The library allows the user to send many options directly to `ofetch`. There is no filter on which options are available. We can abuse the retry logic to cause the server to crash from a stack overflow. fetchOptions are obtained directly from the request body. A malicious user can construct a URL known  to not fetch successfully, then set the retry attempts to a high value, this will cause a stack overflow as ofetch error handling works recursively resulting in a denial of service. This issue has been addressed in version 0.22.1. Users are advised to upgrade. Users unable to upgrade should limit ofetch options.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service by abusing `fetchOptions.retry` in nuxt-api-party","id":"CVE-2023-49800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Lif Auth Server vulnerable to uncontrolled data in path expression","id":"CVE-2023-49801"},"packages":[{"ecosystem":"npm","fixed":["0.22.1"],"introduced":["0"],"last_affected":[],"package":"nuxt-api-party","purl":null,"source":"GHSA-q6hx-3m4p-749h"},{"ecosystem":"npm","fixed":["0.22.1"],"introduced":["0"],"last_affected":[],"package":"nuxt-api-party","purl":"pkg:npm/nuxt-api-party","source":"GHSA-q6hx-3m4p-749h"}],"prev":{"headline":"Server-Side Request Forgery in nuxt-api-party","id":"CVE-2023-49799"},"products":["nuxt-api-party"],"published":"2023-12-08","related":[{"cvss_score":7.5,"headline":"Server-Side Request Forgery in nuxt-api-party","id":"CVE-2023-49799","kev_date_added":null,"published":"2023-12-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["johannschopplich"]},"summary":"Attackers can crash the server via stack overflow by abusing unfiltered retry options in the nuxt-api-party module.","url":"https://insights.sbomify.com/CVE-2023-49800/"}